summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-07-02 20:13:25 -0500
committerZach van Rijn <me@zv.io>2022-10-21 18:34:01 -0500
commit70f899055f40b6d3ae191c88c842267a95199e46 (patch)
treecb2221b5e1a7b147d97ef90d541dad7be51d67e6
parent4693ca07c6a9ea6d954697224af118ee0fa0d028 (diff)
downloadpackages-70f899055f40b6d3ae191c88c842267a95199e46.tar.gz
packages-70f899055f40b6d3ae191c88c842267a95199e46.tar.bz2
packages-70f899055f40b6d3ae191c88c842267a95199e46.tar.xz
packages-70f899055f40b6d3ae191c88c842267a95199e46.zip
user/wayland-protocols: Update to 1.25, fix tests
-rw-r--r--user/wayland-protocols/APKBUILD11
-rw-r--r--user/wayland-protocols/test.patch66
2 files changed, 73 insertions, 4 deletions
diff --git a/user/wayland-protocols/APKBUILD b/user/wayland-protocols/APKBUILD
index b313fbc95..0972f74c0 100644
--- a/user/wayland-protocols/APKBUILD
+++ b/user/wayland-protocols/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
-# Maintainer: Sheila Aman <sheila@vulpine.house>
+# Maintainer: Sile Ekaterin Liszka <sheila@vulpine.house>
pkgname=wayland-protocols
-pkgver=1.24
+pkgver=1.25
pkgrel=0
pkgdesc="Protocols and protocol extensions complementing the Wayland core protocol"
url="https://wayland.freedesktop.org"
@@ -11,7 +11,9 @@ depends=""
makedepends="wayland-dev meson"
subpackages=""
provides="$pkgname-dev"
-source="https://wayland.freedesktop.org/releases/$pkgname-$pkgver.tar.xz"
+source="https://wayland.freedesktop.org/releases/$pkgname-$pkgver.tar.xz
+ test.patch
+ "
build() {
meson \
@@ -34,4 +36,5 @@ package() {
DESTDIR="$pkgdir" ninja -C build install
}
-sha512sums="4b1122517db56f48a5fafd4bd0cb7f94faef6fdd2d80e6cec17e5a6bafbaf2f5a71b958ed12e6d13965494885c209b2fb6dd8331487b39c6f251e71f1e770a15 wayland-protocols-1.24.tar.xz"
+sha512sums="8269694a0780e4d32f1982ff4cbb50b1ef85f08157b9486bc6d7e489c64665a9d9f959121d0eede7c7b108a604d974b64d74cfdef8b5f14304465309afb0768f wayland-protocols-1.25.tar.xz
+659220b5e3fab4a2e6bb017d6fde33fd2cb1424e9e8778829c089e2f422abcdbaae44661ab9c62160046ccf8c3b397da055478194690de057758563d18c62610 test.patch"
diff --git a/user/wayland-protocols/test.patch b/user/wayland-protocols/test.patch
new file mode 100644
index 000000000..b7a5e26ea
--- /dev/null
+++ b/user/wayland-protocols/test.patch
@@ -0,0 +1,66 @@
+xdg-decoration-unstable-v1 needs xdg-toplevel but does not define it.
+This leads to a linker failure on at least ppc64.
+
+--- wayland-protocols-1.25/tests/meson.build.old 2022-01-28 10:00:40.731421000 -0600
++++ wayland-protocols-1.25/tests/meson.build 2022-07-02 20:09:54.653454716 -0500
+@@ -88,32 +88,34 @@
+ ]
+
+ # Check that header can be included by a pedantic C99 compiler
+- test_name = 'test-build-pedantic-@0@'.format(protocol_file.underscorify())
+- test_name_source = '@0@.c'.format(test_name)
+- test_source = custom_target(
+- test_name_source,
+- input: 'build-pedantic.c.in',
+- output: test_name_source,
+- command: replace_command,
+- )
+- pedantic_test_executable = executable(
+- test_name,
+- [
+- test_source,
+- client_header,
+- server_header,
+- code
+- ],
+- link_args: extra_linker_flags,
+- dependencies: libwayland,
+- c_args: [
+- '-std=c99',
+- '-pedantic',
+- '-Wall',
+- '-Werror' ],
+- install: false,
+- )
+- test(test_name, pedantic_test_executable)
++ if not protocol_file.contains('xdg-decoration-unstable-v1')
++ test_name = 'test-build-pedantic-@0@'.format(protocol_file.underscorify())
++ test_name_source = '@0@.c'.format(test_name)
++ test_source = custom_target(
++ test_name_source,
++ input: 'build-pedantic.c.in',
++ output: test_name_source,
++ command: replace_command,
++ )
++ pedantic_test_executable = executable(
++ test_name,
++ [
++ test_source,
++ client_header,
++ server_header,
++ code
++ ],
++ link_args: extra_linker_flags,
++ dependencies: libwayland,
++ c_args: [
++ '-std=c99',
++ '-pedantic',
++ '-Wall',
++ '-Werror' ],
++ install: false,
++ )
++ test(test_name, pedantic_test_executable)
++ endif
+
+ # Check that the header
+ if not protocol_file.contains('xdg-foreign-unstable-v1')