summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 00:38:18 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 00:38:18 +0000
commit7417c7aaf9619beaa518e0b4f392074dcee66724 (patch)
tree4f0bb3de3de0c3c818a8d4faace5914c84af07bb
parent53d65f2558b41eb6e7140565dc30e2dcb44fc017 (diff)
downloadpackages-7417c7aaf9619beaa518e0b4f392074dcee66724.tar.gz
packages-7417c7aaf9619beaa518e0b4f392074dcee66724.tar.bz2
packages-7417c7aaf9619beaa518e0b4f392074dcee66724.tar.xz
packages-7417c7aaf9619beaa518e0b4f392074dcee66724.zip
system/f*: press 'f' to pay respects to old metadata
-rw-r--r--system/fakeroot/APKBUILD2
-rw-r--r--system/fcron/APKBUILD8
-rw-r--r--system/file/APKBUILD6
-rw-r--r--system/findutils/APKBUILD4
-rw-r--r--system/flex/APKBUILD3
5 files changed, 8 insertions, 15 deletions
diff --git a/system/fakeroot/APKBUILD b/system/fakeroot/APKBUILD
index 146fff618..4066aff0b 100644
--- a/system/fakeroot/APKBUILD
+++ b/system/fakeroot/APKBUILD
@@ -2,7 +2,7 @@
pkgname=fakeroot
pkgver=1.24
pkgrel=0
-pkgdesc="Utility to provide a 'fake' root environment as a non-privileged user"
+pkgdesc="Tool for simulating superuser privileges"
arch="all"
license="GPL-3.0+"
url="https://wiki.debian.org/FakeRoot"
diff --git a/system/fcron/APKBUILD b/system/fcron/APKBUILD
index 6b2998814..8f80e488d 100644
--- a/system/fcron/APKBUILD
+++ b/system/fcron/APKBUILD
@@ -3,23 +3,22 @@
pkgname=fcron
pkgver=3.2.1
pkgrel=3
-pkgdesc="periodical command scheduler for systems not always up"
+pkgdesc="Task scheduler"
url="http://fcron.free.fr/"
-pkgusers="fcron"
-pkggroups="fcron"
arch="all"
options="suid !check" # No test suite.
license="GPL"
depends="cmd:sendmail vim"
makedepends="perl"
install="fcron.pre-install"
+pkgusers="fcron"
+pkggroups="fcron"
subpackages="$pkgname-doc $pkgname-openrc"
source="http://fcron.free.fr/archives/${pkgname}-${pkgver}.src.tar.gz
systab.orig
fcron.initd"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -37,7 +36,6 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir/" install
install -Dm775 "$srcdir"/fcron.initd "$pkgdir"/etc/init.d/fcron
rm -r "$pkgdir"/var/run
diff --git a/system/file/APKBUILD b/system/file/APKBUILD
index 86a09ce68..da9059a2b 100644
--- a/system/file/APKBUILD
+++ b/system/file/APKBUILD
@@ -8,17 +8,17 @@ pkgdesc="File type identification utility"
url="http://www.darwinsys.com/file/"
arch="all"
license="BSD-2-Clause"
+depends=""
+makedepends="autoconf automake"
subpackages="$pkgname-dev $pkgname-doc libmagic"
source="$pkgname-$pkgver.tar.gz::https://github.com/file/file/archive/FILE${pkgver%.*}_${pkgver#*.}.tar.gz"
builddir="$srcdir/$pkgname-FILE${pkgver%.*}_${pkgver#*.}"
prepare() {
- cd "$builddir"
autoreconf -vif
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -28,12 +28,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/system/findutils/APKBUILD b/system/findutils/APKBUILD
index c789cd3a0..dc97a9de3 100644
--- a/system/findutils/APKBUILD
+++ b/system/findutils/APKBUILD
@@ -4,13 +4,13 @@
pkgname=findutils
pkgver=4.7.0
pkgrel=0
-pkgdesc="GNU utilities for finding files"
+pkgdesc="GNU utilities to locate files"
url="https://www.gnu.org/software/findutils/"
arch="all"
license="GPL-3.0+"
depends=""
-makedepends=""
checkdepends="coreutils diffutils dejagnu"
+makedepends=""
subpackages="$pkgname-doc $pkgname-lang"
source="https://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz
gnulib-tests-dont-require-gpg-passphrase.patch
diff --git a/system/flex/APKBUILD b/system/flex/APKBUILD
index f900c0a75..f49c259d0 100644
--- a/system/flex/APKBUILD
+++ b/system/flex/APKBUILD
@@ -14,7 +14,6 @@ subpackages="$pkgname-doc $pkgname-lang $pkgname-libs $pkgname-dev"
source="https://github.com/westes/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -29,12 +28,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make install DESTDIR="$pkgdir"
ln -s flex "$pkgdir"/usr/bin/lex
}