summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2020-12-29 05:03:24 -0500
committerMax Rees <maxcrees@me.com>2020-12-30 03:01:07 -0500
commit81b7fc8134227551cf3b3f11653f83cfbc8672c4 (patch)
tree4eea5ed5d7d6f927be919ceb7bd9fa0e7545972c
parent3465fcf878a4f0e00a9378a4299eaa48a0af5bea (diff)
downloadpackages-81b7fc8134227551cf3b3f11653f83cfbc8672c4.tar.gz
packages-81b7fc8134227551cf3b3f11653f83cfbc8672c4.tar.bz2
packages-81b7fc8134227551cf3b3f11653f83cfbc8672c4.tar.xz
packages-81b7fc8134227551cf3b3f11653f83cfbc8672c4.zip
user/py3-flup: new package
-rw-r--r--user/py3-flup/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/user/py3-flup/APKBUILD b/user/py3-flup/APKBUILD
new file mode 100644
index 000000000..c9b0013f7
--- /dev/null
+++ b/user/py3-flup/APKBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=py3-flup
+_pkgname=${pkgname#py3-}
+pkgver=1.0.3
+pkgrel=0
+pkgdesc="Python WSGI module collection"
+url="https://www.saddi.com/software/flup/"
+arch="noarch"
+options="!check" # No test suite.
+license="BSD-2-Clause"
+depends="python3"
+makedepends=""
+source="https://files.pythonhosted.org/packages/source/f/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="f165685b39a8539d29d48d0ad3c9c0495f428892b8935545a128730687c658a1e8b74a09c8084dd4a2490b1d26f1382b48c95ba43401171fd46876b068ba2f8e flup-1.0.3.tar.gz"