summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2016-12-12 23:16:40 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2016-12-12 23:16:40 -0600
commit87b911b2b62bf02bf99c91ab27b14b27991e0723 (patch)
treecf8632141a401996bfc98656417c496f3b00a1a0
parent63be2fd6770f06d2d98e3ba7b11071a7c91f7a6e (diff)
downloadpackages-87b911b2b62bf02bf99c91ab27b14b27991e0723.tar.gz
packages-87b911b2b62bf02bf99c91ab27b14b27991e0723.tar.bz2
packages-87b911b2b62bf02bf99c91ab27b14b27991e0723.tar.xz
packages-87b911b2b62bf02bf99c91ab27b14b27991e0723.zip
x11-libs/cairo: bump for Xcb support (for i3lock)
-rw-r--r--profiles/base/package.use3
-rw-r--r--x11-libs/cairo/Manifest1
-rw-r--r--x11-libs/cairo/cairo-1.14.6-r99.ebuild161
-rw-r--r--x11-libs/cairo/files/cairo-1.12.18-disable-test-suite.patch15
-rw-r--r--x11-libs/cairo/files/cairo-respect-fontconfig.patch13
5 files changed, 192 insertions, 1 deletions
diff --git a/profiles/base/package.use b/profiles/base/package.use
index 62a2cb296..75ac81fa9 100644
--- a/profiles/base/package.use
+++ b/profiles/base/package.use
@@ -44,7 +44,7 @@ x11-drivers/xf86-video-nouveau glamor
x11-drivers/xf86-video-r128 dri
x11-drivers/xf86-video-savage dri
x11-drivers/xf86-video-tdfx dri
-x11-libs/cairo X opengl
+x11-libs/cairo X opengl xcb
x11-libs/gdk-pixbuf X jpeg jpeg2k tiff
x11-libs/libdrm libkms
x11-libs/libva X
@@ -119,6 +119,7 @@ media-libs/netpbm X jpeg jpeg2k png rle tiff zlib
media-libs/urt X gif tiff
net-libs/gnutls -dane
x11-libs/gtk+:3 X xinerama
+x11-libs/libfm automount gtk exif udisks -vala
x11-misc/xscreensaver jpeg new-login opengl pam perl xinerama
xfce-base/thunar dbus exif libnotify udisks
xfce-base/xfce4-session policykit upower xscreensaver
diff --git a/x11-libs/cairo/Manifest b/x11-libs/cairo/Manifest
new file mode 100644
index 000000000..c11ba49ee
--- /dev/null
+++ b/x11-libs/cairo/Manifest
@@ -0,0 +1 @@
+DIST cairo-1.14.6.tar.xz 36040596 SHA256 613cb38447b76a93ff7235e17acd55a78b52ea84a9df128c3f2257f8eaa7b252 SHA512 e2aa17a33b95b68d407b53ac321cca15b0c148eb49b8639c75b2af1e75e7b417a2168ea978dabb8581b341f0f45dc042d3b1a56b01ab525b1984015f0865316b WHIRLPOOL cf58eff36277d013225e5a76a9f0d8530012502a3f125c417085ddc9ad7997ab180468783ae6a702a15ac4a3f4c0b5406170a6e6504785bf7de3a9e3b511b48f
diff --git a/x11-libs/cairo/cairo-1.14.6-r99.ebuild b/x11-libs/cairo/cairo-1.14.6-r99.ebuild
new file mode 100644
index 000000000..8e68195b1
--- /dev/null
+++ b/x11-libs/cairo/cairo-1.14.6-r99.ebuild
@@ -0,0 +1,161 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic autotools multilib-minimal
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/cairo"
+ SRC_URI=""
+else
+ SRC_URI="http://cairographics.org/releases/${P}.tar.xz"
+ KEYWORDS="alpha amd64 arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="A vector graphics library with cross-device output support"
+HOMEPAGE="http://cairographics.org/"
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+IUSE="X aqua debug directfb gles2 +glib opengl static-libs +svg valgrind xcb xlib-xcb"
+# gtk-doc regeneration doesn't seem to work with out-of-source builds
+#[[ ${PV} == *9999* ]] && IUSE="${IUSE} doc" # API docs are provided in tarball, no need to regenerate
+
+# Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
+RESTRICT="test"
+
+RDEPEND=">=dev-libs/lzo-2.06-r1[${MULTILIB_USEDEP}]
+ >=media-libs/fontconfig-2.10.92[${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.5.0.1:2[${MULTILIB_USEDEP}]
+ >=media-libs/libpng-1.6.10:0=[${MULTILIB_USEDEP}]
+ sys-libs/binutils-libs:0=[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/pixman-0.32.4[${MULTILIB_USEDEP}]
+ directfb? ( dev-libs/DirectFB )
+ gles2? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
+ glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
+ opengl? ( || ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] media-libs/opengl-apple ) )
+ X? (
+ >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ )
+ xcb? (
+ >=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
+ )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20131008-r1
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/libtool-2
+ X? (
+ >=x11-proto/renderproto-0.11.1-r1[${MULTILIB_USEDEP}]
+ )"
+#[[ ${PV} == *9999* ]] && DEPEND="${DEPEND}
+# doc? (
+# >=dev-util/gtk-doc-1.6
+# ~app-text/docbook-xml-dtd-4.2
+# )"
+
+REQUIRED_USE="
+ gles2? ( !opengl )
+ xlib-xcb? ( xcb )
+"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/cairo/cairo-directfb.h
+)
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.12.18-disable-test-suite.patch
+ epatch "${FILESDIR}"/${PN}-respect-fontconfig.patch
+
+ # tests and perf tools require X, bug #483574
+ if ! use X; then
+ sed -e '/^SUBDIRS/ s#boilerplate test perf# #' -i Makefile.am || die
+ fi
+
+ epatch_user
+
+ # Slightly messed build system YAY
+ if [[ ${PV} == *9999* ]]; then
+ touch boilerplate/Makefile.am.features
+ touch src/Makefile.am.features
+ touch ChangeLog
+ fi
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myopts
+
+ [[ ${CHOST} == *-interix* ]] && append-flags -D_REENTRANT
+
+ use elibc_FreeBSD && myopts+=" --disable-symbol-lookup"
+ [[ ${CHOST} == *-darwin* ]] && myopts+=" --disable-symbol-lookup"
+
+ # TODO: remove this (and add USE-dep) when DirectFB is converted,
+ # bug #484248 -- but beware of the circular dep.
+ if ! multilib_is_native_abi; then
+ myopts+=" --disable-directfb"
+ fi
+
+ # TODO: remove this (and add USE-dep) when qtgui is converted, bug #498010
+ if ! multilib_is_native_abi; then
+ myopts+=" --disable-qt"
+ fi
+
+ # [[ ${PV} == *9999* ]] && myopts+=" $(use_enable doc gtk-doc)"
+
+ ECONF_SOURCE="${S}" \
+ econf \
+ --disable-dependency-tracking \
+ $(use_with X x) \
+ $(use_enable X tee) \
+ $(use_enable X xlib) \
+ $(use_enable X xlib-xrender) \
+ $(use_enable aqua quartz) \
+ $(use_enable aqua quartz-image) \
+ $(use_enable debug test-surfaces) \
+ $(use_enable directfb) \
+ $(use_enable gles2 glesv2) \
+ $(use_enable glib gobject) \
+ $(use_enable opengl gl) \
+ $(use_enable static-libs static) \
+ $(use_enable svg) \
+ $(use_enable valgrind) \
+ $(use_enable xcb) \
+ $(use_enable xcb xcb-shm) \
+ $(use_enable xlib-xcb) \
+ --enable-ft \
+ --enable-pdf \
+ --enable-png \
+ --enable-ps \
+ --disable-drm \
+ --disable-gallium \
+ --disable-qt \
+ --disable-vg \
+ ${myopts}
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --all
+ einstalldocs
+}
+
+pkg_postinst() {
+ if use !xlib-xcb; then
+ if has_version net-misc/nxserver-freenx \
+ || has_version net-misc/x2goserver; then
+ ewarn "cairo-1.12 is known to cause GTK+ errors with NX servers."
+ ewarn "Enable USE=\"xlib-xcb\" if you notice incorrect behavior in GTK+"
+ ewarn "applications that are running inside NX sessions. For details, see"
+ ewarn "https://bugs.gentoo.org/441878 or https://bugs.freedesktop.org/59173"
+ fi
+ fi
+}
diff --git a/x11-libs/cairo/files/cairo-1.12.18-disable-test-suite.patch b/x11-libs/cairo/files/cairo-1.12.18-disable-test-suite.patch
new file mode 100644
index 000000000..6822121ce
--- /dev/null
+++ b/x11-libs/cairo/files/cairo-1.12.18-disable-test-suite.patch
@@ -0,0 +1,15 @@
+diff --git a/Makefile.am b/Makefile.am
+index 03fa352..7e11d24 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -18,10 +18,6 @@ ACLOCAL_AMFLAGS = -I build ${ACLOCAL_FLAGS}
+
+ DIST_SUBDIRS = src doc util boilerplate test perf
+ SUBDIRS = src doc util
+-# libpng is required for our test programs
+-if CAIRO_HAS_PNG_FUNCTIONS
+-SUBDIRS += boilerplate test perf
+-endif
+
+ configure: cairo-version.h
+
diff --git a/x11-libs/cairo/files/cairo-respect-fontconfig.patch b/x11-libs/cairo/files/cairo-respect-fontconfig.patch
new file mode 100644
index 000000000..b0a1b2963
--- /dev/null
+++ b/x11-libs/cairo/files/cairo-respect-fontconfig.patch
@@ -0,0 +1,13 @@
+--- cairo-1.7.6-orig/src/cairo-ft-font.c 2008-09-29 21:43:13.000000000 +0100
++++ cairo-1.7.6/src/cairo-ft-font.c 2008-09-29 21:52:19.000000000 +0100
+@@ -1705,7 +1705,9 @@
+ options->base.subpixel_order = other->base.subpixel_order;
+ }
+
+- if (options->base.hint_style == CAIRO_HINT_STYLE_DEFAULT)
++ options->base.hint_style = CAIRO_HINT_STYLE_DEFAULT;
++
++ if (other->base.hint_style != CAIRO_HINT_STYLE_DEFAULT)
+ options->base.hint_style = other->base.hint_style;
+
+ if (other->base.hint_style == CAIRO_HINT_STYLE_NONE)