summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-02-25 11:02:47 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-02-25 11:02:47 +0000
commit8e25d8a6cb0e83d12bb2335f4d3026f6a1b5aa93 (patch)
tree57f0ba127859852998c49c67db1add256b7fcc48
parentf60b90c13e60e9b4f77450bc0e705c4e287ee30e (diff)
downloadpackages-8e25d8a6cb0e83d12bb2335f4d3026f6a1b5aa93.tar.gz
packages-8e25d8a6cb0e83d12bb2335f4d3026f6a1b5aa93.tar.bz2
packages-8e25d8a6cb0e83d12bb2335f4d3026f6a1b5aa93.tar.xz
packages-8e25d8a6cb0e83d12bb2335f4d3026f6a1b5aa93.zip
system/man-db: Bump to 2.9.0
-rw-r--r--system/man-db/APKBUILD6
-rw-r--r--system/man-db/man-db-2.8.5-iconv.patch22
2 files changed, 12 insertions, 16 deletions
diff --git a/system/man-db/APKBUILD b/system/man-db/APKBUILD
index 411767d07..5ee93c438 100644
--- a/system/man-db/APKBUILD
+++ b/system/man-db/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=man-db
-pkgver=2.8.6.1
+pkgver=2.9.0
pkgrel=0
pkgdesc="The man command and related utilities for examining on-line help files"
url="https://www.nongnu.org/man-db/"
@@ -40,5 +40,5 @@ package() {
rm -r "${pkgdir}"/usr/lib/tmpfiles.d # systemd
}
-sha512sums="0c43cdddf2e07cd4a2225e098ea4cbfb2842a9bbf08bfb073058be0d66efac3a77ca0f8725564677c8f61e671f471c76f1dbba77a7601d7a63bb81350ef51bb5 man-db-2.8.6.1.tar.xz
-76a5b13d3018627cbc5a72cb51da3c78022245ad574c742699e7c4ab152ec2222ce7f34af5594de74b436dd23008af6c43739ee66973e049b07d82882e4965c6 man-db-2.8.5-iconv.patch"
+sha512sums="7deb4421c7944276c6edf974b1336ee2f6605ee470c98d374544e2fcaa32ec2afe077c5fd020fc1f74df058384a293b8ad5a92d86b1c15a949573af46ba09cda man-db-2.9.0.tar.xz
+0a68260fc48488408dc11855858aa2569efa3aeefd765c425b8fc988e7fee3e1d42e19eb299e518afc9b2ae54c5d37911176127124a43d5041f1137af0457097 man-db-2.8.5-iconv.patch"
diff --git a/system/man-db/man-db-2.8.5-iconv.patch b/system/man-db/man-db-2.8.5-iconv.patch
index 8c006fd9c..c2232920d 100644
--- a/system/man-db/man-db-2.8.5-iconv.patch
+++ b/system/man-db/man-db-2.8.5-iconv.patch
@@ -1,6 +1,6 @@
--- man-db-2.8.5/src/man.c 2018-06-18 22:44:35.672743065 -0500
+++ man-db-2.8.5/src/man.c 2018-06-18 22:46:35.032624890 -0500
-@@ -1569,15 +1569,13 @@
+@@ -1516,15 +1516,13 @@
{
debug ("add_output_iconv: source %s, target %s\n", source, target);
if (source && target && !STREQ (source, target)) {
@@ -19,23 +19,19 @@
--- man-db-2.8.5/src/manconv.c
+++ man-db-2.8.5/src/manconv.c
-@@ -106,10 +106,9 @@ static int try_iconv (pipeline *p, const char *try_from_code, const char *to,
- static char *utf8 = NULL, *output = NULL;
- size_t utf8left = 0;
+@@ -111,6 +111,5 @@ static int try_iconv (pipeline *p, const char *try_from_code, const char *to,
iconv_t cd_utf8, cd = NULL;
-- int to_utf8 = STREQ (try_to_code, "UTF-8") ||
-- STRNEQ (try_to_code, "UTF-8//", 7);
+- bool to_utf8 = STREQ (try_to_code, "UTF-8") ||
+- STRNEQ (try_to_code, "UTF-8//", 7);
- const char *utf8_target = last ? "UTF-8//IGNORE" : "UTF-8";
-- int ignore_errors = (strstr (try_to_code, "//IGNORE") != NULL);;
-+ int to_utf8 = STREQ (try_to_code, "UTF-8");
+- bool ignore_errors = (strstr (try_to_code, "//IGNORE") != NULL);
++ bool to_utf8 = STREQ (try_to_code, "UTF-8");
+ const char *utf8_target = "UTF-8";
-+ int ignore_errors = 0;
++ bool ignore_errors = 0;
int ret = 0;
-
- debug ("trying encoding %s -> %s\n", try_from_code, try_to_code);
--- man-db-2.8.5/src/manconv_client.c
+++ man-db-2.8.5/src/manconv_client.c
-@@ -105,7 +105,7 @@ void add_manconv (pipeline *p, const char *source, const char *target)
+@@ -102,7 +102,7 @@ void add_manconv (pipeline *p, const char *source, const char *target)
codes->from[2] = NULL;
name = appendstr (name, "UTF-8:", source, (void *) 0);
}
@@ -58,7 +54,7 @@
debug_level = 1;
--- man-db-2.8.5/src/whatis.c
+++ man-db-2.8.5/src/whatis.c
-@@ -974,7 +974,7 @@ int main (int argc, char *argv[])
+@@ -945,7 +945,7 @@ int main (int argc, char *argv[])
display_seen = hashtable_create (&null_hashtable_free);
#ifdef HAVE_ICONV