summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-04-25 11:01:58 -0500
committerZach van Rijn <me@zv.io>2022-10-21 18:33:58 -0500
commit923e1baa9ce4c6c6010812eae085c3c04c75e412 (patch)
tree77b0542c067c2764eda1907472555665af1a7cb7
parent0263e416fa3ebe1b6f0d2b34b45241e1e1755b45 (diff)
downloadpackages-923e1baa9ce4c6c6010812eae085c3c04c75e412.tar.gz
packages-923e1baa9ce4c6c6010812eae085c3c04c75e412.tar.bz2
packages-923e1baa9ce4c6c6010812eae085c3c04c75e412.tar.xz
packages-923e1baa9ce4c6c6010812eae085c3c04c75e412.zip
user/lsof: test suite: do not prompt for input. fixes #552.
-rw-r--r--user/lsof/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/user/lsof/APKBUILD b/user/lsof/APKBUILD
index 5330d1a7a..abf4075b5 100644
--- a/user/lsof/APKBUILD
+++ b/user/lsof/APKBUILD
@@ -34,7 +34,9 @@ check() {
# The LTsock test will fail if /etc/hosts is not set correctly.
# Make sure that 127.0.0.1 and ::1 have aliases corresponding to
# `hostname`.
- printf "y" | make -C tests
+ sed -i tests/CkTestDB \
+ -e 's/^# This dialect may never have been validated.*$/exit 0/'
+ make -C tests
make -C tests opt
}