summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-08 18:32:26 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-08 18:32:26 -0500
commit998eb52d89368739a42801393dcf0d2c12097cb2 (patch)
treeeb597e38b0ecc58d00092acb3915fb7c3448ed65
parentef134e9f746b822829c710f374aa9ba977c4023c (diff)
downloadpackages-998eb52d89368739a42801393dcf0d2c12097cb2.tar.gz
packages-998eb52d89368739a42801393dcf0d2c12097cb2.tar.bz2
packages-998eb52d89368739a42801393dcf0d2c12097cb2.tar.xz
packages-998eb52d89368739a42801393dcf0d2c12097cb2.zip
user/libxshmfence: pull in, bump, take, fix
-rw-r--r--user/libxshmfence/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/user/libxshmfence/APKBUILD b/user/libxshmfence/APKBUILD
new file mode 100644
index 000000000..1608eb19d
--- /dev/null
+++ b/user/libxshmfence/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=libxshmfence
+pkgver=1.3
+pkgrel=0
+pkgdesc="X11 shared memory fences"
+url="https://www.X.Org/"
+arch="all"
+license="MIT"
+depends=""
+depends_dev="linux-headers"
+makedepends="$depends_dev util-macros xorgproto-dev"
+subpackages="$pkgname-dev"
+source="https://www.X.Org/releases/individual/lib/libxshmfence-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-static \
+ --enable-futex
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="c446e055f8fac62b9aa266132289a4cfc030282147974c45ce96d1768a98d1afb997470e58e4a68513174c404cbf373bdde2f0cd4b34abdbce1d89dd0b6fe2b7 libxshmfence-1.3.tar.bz2"