summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-12 09:18:00 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-12 09:18:00 +0000
commit9a06b438011da81cdf515d5098c7355e86f4b8cf (patch)
tree5a260785057d4078fb1ca2e2fef334059306a3a4
parent8d0d655512e729ef73e5f6b3b140ec34ccfb9e51 (diff)
downloadpackages-9a06b438011da81cdf515d5098c7355e86f4b8cf.tar.gz
packages-9a06b438011da81cdf515d5098c7355e86f4b8cf.tar.bz2
packages-9a06b438011da81cdf515d5098c7355e86f4b8cf.tar.xz
packages-9a06b438011da81cdf515d5098c7355e86f4b8cf.zip
user/tmux: Bump to 3.0a
-rw-r--r--user/tmux/APKBUILD15
-rw-r--r--user/tmux/xterm-DECLRMM.patch23
2 files changed, 6 insertions, 32 deletions
diff --git a/user/tmux/APKBUILD b/user/tmux/APKBUILD
index eed2ea5e2..b39d4a3b6 100644
--- a/user/tmux/APKBUILD
+++ b/user/tmux/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer:
pkgname=tmux
-pkgver=2.9a
-pkgrel=1
+pkgver=3.0a
+pkgrel=0
pkgdesc="Tool to control multiple terminals from a single terminal"
url="https://tmux.github.io/"
arch="all"
@@ -10,8 +10,7 @@ license="MIT"
depends="ncurses-terminfo"
makedepends="bsd-compat-headers libevent-dev libutempter-dev ncurses-dev"
subpackages="$pkgname-doc"
-source="https://github.com/tmux/tmux/releases/download/$pkgver/$pkgname-$pkgver.tar.gz
- xterm-DECLRMM.patch"
+source="https://github.com/tmux/tmux/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
build() {
./configure \
@@ -33,10 +32,8 @@ package() {
install -Dm644 example_tmux.conf \
"$pkgdir"/usr/share/doc/$pkgname/examples/$pkgname.conf
- for file in CHANGES README TODO; do
- install -m644 "$file" "$pkgdir"/usr/share/doc/$pkgname/
- done
+ install -m644 "CHANGES" "$pkgdir"/usr/share/doc/$pkgname/
+ install -m644 "README" "$pkgdir"/usr/share/doc/$pkgname/
}
-sha512sums="aca6882688727c10c5647443fdd18bbd6c0f80b7a3bf9667903d1b89d523e604cd715f176f33f2e5673258f00e626a6dc273f80fe97ae4f91621814d89985713 tmux-2.9a.tar.gz
-7fb006f8f24d60614fcaeadace933c2ad6674d2476980736a830f63a40d7110638942478322336849d47707c99ab7de0cb01ff39806a4c9144650daf2f666773 xterm-DECLRMM.patch"
+sha512sums="f326ee9c0e5e9a46ce9c99c76407b8cf35feea5f898c3c937fd8c5e488ff9a809272de19226d9d10f864e11051dcf633327820b7f8d86d85962da61174bbfb0b tmux-3.0a.tar.gz"
diff --git a/user/tmux/xterm-DECLRMM.patch b/user/tmux/xterm-DECLRMM.patch
deleted file mode 100644
index b9bef3455..000000000
--- a/user/tmux/xterm-DECLRMM.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 26f274011096b9eacfd2753d8f7afcb63e796ab9 Mon Sep 17 00:00:00 2001
-From: nicm <nicm>
-Date: Thu, 1 Aug 2019 11:45:34 +0000
-Subject: [PATCH] xterm 348 now disables margins when resized, so send DECLRMM
- again.
-
----
- tty.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/tty.c b/tty.c
-index ab1da9fd3..024aef271 100644
---- a/tty.c
-+++ b/tty.c
-@@ -1879,6 +1879,8 @@ tty_invalidate(struct tty *tty)
- tty->rlower = tty->rright = UINT_MAX;
-
- if (tty->flags & TTY_STARTED) {
-+ if (tty_use_margin(tty))
-+ tty_puts(tty, "\033[?69h"); /* DECLRMM */
- tty_putcode(tty, TTYC_SGR0);
-
- tty->mode = ALL_MODES;