summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 01:00:56 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 01:00:56 +0000
commit9a841fe2af5204c11e54bdb00a8f46088b30de7d (patch)
treec036b83ca4ac76a15eaa4c833523abddbcd290d4
parent7833fcbe0f814b7ca0ea9bf5da6d0381de9c7d10 (diff)
downloadpackages-9a841fe2af5204c11e54bdb00a8f46088b30de7d.tar.gz
packages-9a841fe2af5204c11e54bdb00a8f46088b30de7d.tar.bz2
packages-9a841fe2af5204c11e54bdb00a8f46088b30de7d.tar.xz
packages-9a841fe2af5204c11e54bdb00a8f46088b30de7d.zip
system/l*: modernise, fix metadata, etc
-rw-r--r--system/lddtree/APKBUILD1
-rw-r--r--system/less/APKBUILD4
-rw-r--r--system/libarchive/APKBUILD3
-rw-r--r--system/libcap-ng/APKBUILD1
-rw-r--r--system/libcap/APKBUILD2
-rw-r--r--system/libelf/APKBUILD4
-rw-r--r--system/libffi/APKBUILD2
-rw-r--r--system/libidn/APKBUILD11
-rw-r--r--system/libmnl/APKBUILD6
-rw-r--r--system/libtool/APKBUILD11
-rw-r--r--system/libucontext/APKBUILD6
-rw-r--r--system/linenoise/APKBUILD2
-rw-r--r--system/linux-pam/APKBUILD8
-rw-r--r--system/lua5.3/APKBUILD14
-rw-r--r--system/lutok/APKBUILD6
-rw-r--r--system/lzo/APKBUILD4
-rw-r--r--system/lzop/APKBUILD4
17 files changed, 19 insertions, 70 deletions
diff --git a/system/lddtree/APKBUILD b/system/lddtree/APKBUILD
index 0780a4fd1..fd852f0b0 100644
--- a/system/lddtree/APKBUILD
+++ b/system/lddtree/APKBUILD
@@ -15,7 +15,6 @@ subpackages=""
source="lddtree-$pkgver.tar.gz::https://github.com/ncopa/lddtree/archive/v$pkgver.tar.gz"
package() {
- cd "$builddir"
install -Dm755 lddtree.sh "$pkgdir"/usr/bin/lddtree
}
diff --git a/system/less/APKBUILD b/system/less/APKBUILD
index 871e53965..d958a9189 100644
--- a/system/less/APKBUILD
+++ b/system/less/APKBUILD
@@ -14,13 +14,10 @@ source="http://www.greenwoodsoftware.com/$pkgname/$pkgname-$pkgver.tar.gz"
prepare() {
default_prepare
-
- cd "$builddir"
chmod +x configure
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -32,7 +29,6 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/system/libarchive/APKBUILD b/system/libarchive/APKBUILD
index 18017ee7c..0a19668f0 100644
--- a/system/libarchive/APKBUILD
+++ b/system/libarchive/APKBUILD
@@ -3,11 +3,12 @@
pkgname=libarchive
pkgver=3.4.0
pkgrel=1
-pkgdesc="Library for creating and reading streaming archives"
+pkgdesc="Multi-format archive and compression library"
url="https://libarchive.org/"
arch="all"
options="!check" # needs EUC-JP and KOI8R support in iconv
license="BSD-2-Clause AND BSD-3-Clause AND Public-Domain"
+depends=""
makedepends="zlib-dev bzip2-dev xz-dev lz4-dev acl-dev openssl-dev expat-dev
attr-dev zstd-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
diff --git a/system/libcap-ng/APKBUILD b/system/libcap-ng/APKBUILD
index a31545601..507b87368 100644
--- a/system/libcap-ng/APKBUILD
+++ b/system/libcap-ng/APKBUILD
@@ -6,6 +6,7 @@ pkgdesc="POSIX capabilities library"
url="https://people.redhat.com/sgrubb/libcap-ng/index.html"
arch="all"
license="LGPL-2.1+"
+depends=""
depends_dev="linux-headers"
makedepends="python3 $depends_dev"
makedepends_host="$depends_dev"
diff --git a/system/libcap/APKBUILD b/system/libcap/APKBUILD
index 335d4bcc4..80683e4de 100644
--- a/system/libcap/APKBUILD
+++ b/system/libcap/APKBUILD
@@ -17,12 +17,10 @@ subpackages="$pkgname-doc $pkgname-dev"
source="https://kernel.org/pub/linux/libs/security/linux-privs/libcap2/libcap-$pkgver.tar.xz"
build () {
- cd "$builddir"
make BUILD_CC=gcc CC="${CC:-gcc}" lib=lib prefix=/usr DESTDIR="$pkgdir"
}
package() {
- cd "$builddir"
make lib=/lib prefix=/usr RAISE_SETFCAP=no DESTDIR="$pkgdir" install
}
diff --git a/system/libelf/APKBUILD b/system/libelf/APKBUILD
index 5ddc8884a..3ff6f8583 100644
--- a/system/libelf/APKBUILD
+++ b/system/libelf/APKBUILD
@@ -13,13 +13,11 @@ subpackages="$pkgname-dev"
source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.gz"
prepare() {
- cd "$builddir"
default_prepare
update_config_sub
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -31,12 +29,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make install prefix="$pkgdir"/usr
}
diff --git a/system/libffi/APKBUILD b/system/libffi/APKBUILD
index 07a5be5eb..a917da6f3 100644
--- a/system/libffi/APKBUILD
+++ b/system/libffi/APKBUILD
@@ -2,7 +2,7 @@
pkgname=libffi
pkgver=3.2.1
pkgrel=6
-pkgdesc="A portable, high level programming interface to various calling conventions."
+pkgdesc="A portable foreign function interface library"
url="https://sourceware.org/libffi"
arch="all"
license="MIT"
diff --git a/system/libidn/APKBUILD b/system/libidn/APKBUILD
index 1222c499e..57dd2f485 100644
--- a/system/libidn/APKBUILD
+++ b/system/libidn/APKBUILD
@@ -7,18 +7,15 @@ pkgdesc="Library for internationalized domain names"
url="https://www.gnu.org/software/libidn/"
arch="all"
license="(GPL-2.0+ OR LGPL-3.0+) AND GPL-3.0+"
-depends=
-makedepends=
+depends=""
checkdepends="diffutils"
-install=
+makedepends=""
subpackages="$pkgname-doc $pkgname-dev $pkgname-lang"
source="https://ftp.gnu.org/gnu/libidn/$pkgname-$pkgver.tar.gz
localename-test-fix.patch
gnulib-tests-dont-require-gpg-passphrase.patch
"
-builddir="$srcdir/$pkgname-$pkgver"
-
# secfixes:
# 1.33-r0:
# - CVE-2015-8948
@@ -27,8 +24,6 @@ builddir="$srcdir/$pkgname-$pkgver"
# - CVE-2016-6263
build() {
- cd "$builddir"
-
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -40,12 +35,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/system/libmnl/APKBUILD b/system/libmnl/APKBUILD
index 2826275b1..19d848c8c 100644
--- a/system/libmnl/APKBUILD
+++ b/system/libmnl/APKBUILD
@@ -8,17 +8,15 @@ url="https://www.netfilter.org/projects/libmnl/"
arch="all"
options="!check" # this package doesn't actually run any tests, just builds them
license="LGPL-2.0+"
-depends=
+depends=""
depends_dev="linux-headers"
makedepends="$depends_dev"
checkdepends="bsd-compat-headers"
-install=""
subpackages="$pkgname-dev"
source="https://www.netfilter.org/projects/$pkgname/files/$pkgname-$pkgver.tar.bz2
test-include-sysselect.patch"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,12 +25,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/system/libtool/APKBUILD b/system/libtool/APKBUILD
index c4a3348f9..23de9cb0e 100644
--- a/system/libtool/APKBUILD
+++ b/system/libtool/APKBUILD
@@ -15,7 +15,6 @@ source="https://ftp.gnu.org/gnu/$pkgname/${pkgname}-${pkgver}.tar.gz
libtool-fix-cross-compile.patch"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,18 +24,16 @@ build() {
make
}
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
-}
-
check() {
- cd "$builddir"
# Test 70 and 117 are known to fail
# Test 170 repeats the entire test suite with shorter max_cmd_len
make check TESTSUITEFLAGS="1-69 71-116 118-169"
}
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
libltdl() {
pkgdesc="Runtime libraries for GNU Libtool Dynamic Module Loader"
license="LGPL-2.1+"
diff --git a/system/libucontext/APKBUILD b/system/libucontext/APKBUILD
index 534e6b137..93bc2b252 100644
--- a/system/libucontext/APKBUILD
+++ b/system/libucontext/APKBUILD
@@ -2,11 +2,12 @@
pkgname=libucontext
pkgver=0.9.0
pkgrel=0
-pkgdesc="ucontext function implementations"
+pkgdesc="Implementation of software-defined threading"
url="https://code.foxkit.us/adelie/libucontext/"
arch="all"
license="ISC"
depends=""
+makedepends=""
subpackages="$pkgname-dev"
source="https://distfiles.adelielinux.org/source/libucontext/libucontext-$pkgver.tar.xz"
@@ -18,17 +19,14 @@ pmmx) LIBUCONTEXT_ARCH="x86" ;;
esac
build() {
- cd "$builddir"
make ARCH="$LIBUCONTEXT_ARCH"
}
check() {
- cd "$builddir"
make ARCH="$LIBUCONTEXT_ARCH" check
}
package() {
- cd "$builddir"
make ARCH="$LIBUCONTEXT_ARCH" DESTDIR="$pkgdir" install
}
diff --git a/system/linenoise/APKBUILD b/system/linenoise/APKBUILD
index 5e95f3927..1fd49a51f 100644
--- a/system/linenoise/APKBUILD
+++ b/system/linenoise/APKBUILD
@@ -16,12 +16,10 @@ source="linenoise-$pkgver.tar.gz::https://github.com/antirez/linenoise/archive/$
"
build() {
- cd "$builddir"
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/system/linux-pam/APKBUILD b/system/linux-pam/APKBUILD
index 0d1221a0d..44b603644 100644
--- a/system/linux-pam/APKBUILD
+++ b/system/linux-pam/APKBUILD
@@ -6,12 +6,12 @@ pkgrel=2
pkgdesc="Pluggable Authentication Modules"
url="https://www.kernel.org/pub/linux/libs/pam"
arch="all"
+options="suid"
license="BSD-3-Clause"
depends_dev="gettext-tiny-dev"
makedepends_host="$depends_dev utmps-dev"
makedepends_build="$depends_dev byacc flex-dev autoconf automake libtool"
makedepends="$makedepends_host $makedepends_build"
-options="suid"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://github.com/$pkgname/$pkgname/releases/download/v1.3.1/Linux-PAM-$pkgver.tar.xz
fix-compat.patch
@@ -27,17 +27,15 @@ source="https://github.com/$pkgname/$pkgname/releases/download/v1.3.1/Linux-PAM-
other.pamd
su.pamd
"
-
builddir="$srcdir"/Linux-PAM-$pkgver
+
prepare() {
- cd "$builddir"
default_prepare
# disable insecure modules
sed -e 's/pam_rhosts//g' -i modules/Makefile.am
}
build() {
- cd "$builddir"
autoreconf -vif
[ "$CLIBC" = "musl" ] && export ac_cv_search_crypt=no
LIBS="-lutmps -lskarnet" ./configure \
@@ -54,12 +52,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
# do not install pam.d files bundled with the source, they could be broken
diff --git a/system/lua5.3/APKBUILD b/system/lua5.3/APKBUILD
index 9a90fc7c9..859a7a05b 100644
--- a/system/lua5.3/APKBUILD
+++ b/system/lua5.3/APKBUILD
@@ -4,11 +4,12 @@ _pkgname=lua
pkgver=5.3.5
_luaver=${pkgname#lua}
pkgrel=1
-pkgdesc="Light-weight programming language"
+pkgdesc="Embeddable programming language"
url="https://www.lua.org/"
arch="all"
license="MIT"
ldpath="/usr/lib/$pkgname"
+depends=""
depends_dev="$pkgname"
makedepends="libtool autoconf automake linenoise-dev"
provides="lua"
@@ -27,7 +28,6 @@ builddir="$srcdir/$_pkgname-$pkgver"
prepare() {
default_prepare
- cd "$builddir"
# disable readline
sed -i '/#define LUA_USE_READLINE/d' src/luaconf.h
@@ -44,8 +44,6 @@ prepare() {
}
build() {
- cd "$builddir"
-
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -61,22 +59,18 @@ build() {
}
check() {
- cd "$builddir"
make test
}
package() {
- local i
- cd "$builddir"
-
make V=${pkgver%.*} \
INSTALL_TOP="$pkgdir"/usr \
INSTALL_INC="$pkgdir"/usr/include/$pkgname \
INSTALL_LIB="$pkgdir"/usr/lib/$pkgname \
alpine_install
- for i in "$pkgdir"/usr/lib/$pkgname/*.so.*; do
- ln -s $pkgname/${i##*/} "$pkgdir"/usr/lib/${i##*/}
+ for $_solib in "$pkgdir"/usr/lib/$pkgname/*.so.*; do
+ ln -s $pkgname/${_solib##*/} "$pkgdir"/usr/lib/${_solib##*/}
done
install -D -m 644 doc/lua.1 "$pkgdir"/usr/share/man/man1/lua.1
diff --git a/system/lutok/APKBUILD b/system/lutok/APKBUILD
index 103688367..4ee59e386 100644
--- a/system/lutok/APKBUILD
+++ b/system/lutok/APKBUILD
@@ -10,17 +10,13 @@ depends_dev="lua5.3-dev"
makedepends="$depends_dev"
subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/jmmv/lutok/releases/download/lutok-$pkgver/lutok-$pkgver.tar.gz"
-builddir="$srcdir/lutok-$pkgver"
prepare() {
- cd "$builddir"
default_prepare
update_config_sub
}
build() {
- cd "$builddir"
-
LUA_CFLAGS=$(pkg-config --cflags lua5.3) \
LUA_LIBS=$(pkg-config --libs lua5.3) \
./configure \
@@ -34,12 +30,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
}
diff --git a/system/lzo/APKBUILD b/system/lzo/APKBUILD
index 1707525e0..0e7d8f8d9 100644
--- a/system/lzo/APKBUILD
+++ b/system/lzo/APKBUILD
@@ -10,12 +10,10 @@ arch="all"
license="GPL-2.0+"
depends=""
makedepends=""
-install=
subpackages="$pkgname-dev $pkgname-doc"
source="http://www.oberhumer.com/opensource/lzo/download/$pkgname-$pkgver.tar.gz"
build() {
- cd "$builddir"
CFLAGS="$CFLAGS -DLZO_CFG_NO_SYSCALL=1" \
./configure \
--build=$CBUILD \
@@ -29,12 +27,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/system/lzop/APKBUILD b/system/lzop/APKBUILD
index 030364595..36b179302 100644
--- a/system/lzop/APKBUILD
+++ b/system/lzop/APKBUILD
@@ -9,12 +9,10 @@ arch="all"
license="GPL-2.0+"
depends=""
makedepends="lzo-dev"
-install=""
subpackages="$pkgname-doc"
source="http://www.lzop.org/download/lzop-$pkgver.tar.gz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -26,12 +24,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}