summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-06-03 20:14:26 -0500
committerZach van Rijn <me@zv.io>2024-06-03 21:29:05 -0500
commit9ff128c9c8cd044ff0f2727ca2f80340f43947b3 (patch)
tree0ec03f71dc18a1bfb33ec3cf2a2d076dc3fa513b
parentf279713f57494b7f005531f5812a6676e35cce88 (diff)
downloadpackages-9ff128c9c8cd044ff0f2727ca2f80340f43947b3.tar.gz
packages-9ff128c9c8cd044ff0f2727ca2f80340f43947b3.tar.bz2
packages-9ff128c9c8cd044ff0f2727ca2f80340f43947b3.tar.xz
packages-9ff128c9c8cd044ff0f2727ca2f80340f43947b3.zip
user/gitlab-runner: Update to 15.0.0
-rw-r--r--user/gitlab-runner/APKBUILD17
-rw-r--r--user/gitlab-runner/disable-crap.patch2
-rw-r--r--user/gitlab-runner/fix-multiple-redef-seek.patch20
-rw-r--r--user/gitlab-runner/gccgo.patch10
-rw-r--r--user/gitlab-runner/posix-shell.patch35
-rw-r--r--user/gitlab-runner/tests.patch25
6 files changed, 18 insertions, 91 deletions
diff --git a/user/gitlab-runner/APKBUILD b/user/gitlab-runner/APKBUILD
index 828791646..38aa8e159 100644
--- a/user/gitlab-runner/APKBUILD
+++ b/user/gitlab-runner/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Max Rees <maxcrees@me.com>
# Maintainer: Zach van Rijn <me@zv.io>
pkgname=gitlab-runner
-pkgver=14.0.0
+pkgver=15.0.0
pkgrel=0
_testver=91956efe
_branch="${pkgver%.*}"
@@ -24,15 +24,12 @@ source="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v$pkgver/gitlab-ru
$pkgname.initd
disable-crap.patch
gccgo.patch
- posix-shell.patch
tests.patch
- fix-multiple-redef-seek.patch
"
builddir="$srcdir/$pkgname-v$pkgver"
unpack() {
default_unpack
- mkdir "$builddir"/tmp
mv gitlab-test "$builddir"/tmp
}
@@ -63,7 +60,7 @@ check() {
}
package() {
- install -Dm755 out/binaries/gitlab-runner \
+ install -Dm755 gitlab-runner \
"$pkgdir"/usr/bin/gitlab-runner
install -dm750 -g gitlab-runner \
"$pkgdir"/etc/gitlab-runner
@@ -76,12 +73,10 @@ package() {
"$pkgdir"/etc/init.d/$pkgname
}
-sha512sums="c31cdfa2e090f8b1c262b8ce9e813cf8f6fd3f32aee997909b7ba2d892f484be50554ca01908d99d973ee0cdbeea4fd270b25b77a9739f4d4f002fc9e8b8c3ac gitlab-runner-v14.0.0.tar.gz
+sha512sums="8ba54e690fc45c1e22d174b649fbe3cf78707fd5a146c738c73cba045e6ac00499ddedd7a5f905c0c7e4e804a533d3fc718f8f7ac3c9ec5581de4dd9b3599c80 gitlab-runner-v15.0.0.tar.gz
7bccab81aa1cb88c6a0f83a6d3dfc509e6f9ecb4d0168a5b30cc4e8fdd823294b95fe3633e09757905466f83bb3bf73b1d28fac475dff2dc3164604db4b5b995 gitlab-test-91956efe.tar.gz
f8a0c7e77cd563d7e5b4fb2319181ceab8de44c555cefa4803e985ad3ac6a9fea7bca469d80b28974edcfb65f2095d019bfdf0abd8a3221464276a8d89debc0d gitlab-runner.confd
7f785a65b46919f6a6695e25fdc414ee3204eb9aa1a3735e7884575434af94b20a48f2fe7a1fb787473de23a7bd2d56bc1e9c1fc6b522c6f0c05c47b3d37ab1c gitlab-runner.initd
-92206937f62d79a0dadcc7d666af7f2bd08c53b60db9a12a1a6625af5cd6196a026f68b7bfe90f57b71ce4b6121a3ed5507ec2016290eaf3599a86d2fa545055 disable-crap.patch
-f01dc1f28d003181380d9a0786d156f75572c954e37b527456865db6facffaf2d28a14a984aeef2589a359577cb9a1dffbf9a885ed2cd446dd0bd98e32ed2454 gccgo.patch
-05c12698a7929ed9596e1bb9297588362e5e04e7ad18b64fdab3f3bf2ba39281d658394e1b03dcdd3c1bc5c4c803e608b7c6c92dc6320bd057915a0a7543af4d posix-shell.patch
-baafaa0b66d8e5deff1b8c02e9cc6ce8f1f938be49caecb2aabcd1ea4fc8c967ac3b66af784d1508574cbffa3721f17644d560cb5caafd6873b9b966532c52bd tests.patch
-f2738a531f3db99787ae9e9ec84d5d8d790065e6a56c4170828be06137615829a8908c841103291008a76adc3c1faa1d0f7b6cfb71c68b23b58cf182a0de9c5b fix-multiple-redef-seek.patch"
+020a388f63758ecbcdd19ce3a290d2fd044e852174b6b7e1c79dc39d8d83ac161be5b63df8a9c60da315895e5385e9ac02bd3a46e02d45b96b8f939c90c444cd disable-crap.patch
+6bb477d2f40e651cb59f18ea18cfb051dd06cdfa3f976c6e17b72ee35733e9520a6323cec1f6b34d85fa46050b97bd20d4bb0f08a44f2cbfd4eb6914cfd5d604 gccgo.patch
+9b64665ec4c7f0edb7151b146666ea22283ac109193ff354510da018f14f1442c99707c753e5185caed2eb034600aa93ef5c95d960443339db89696acef96c3c tests.patch"
diff --git a/user/gitlab-runner/disable-crap.patch b/user/gitlab-runner/disable-crap.patch
index 716697b94..aab6a98b1 100644
--- a/user/gitlab-runner/disable-crap.patch
+++ b/user/gitlab-runner/disable-crap.patch
@@ -1,6 +1,6 @@
--- gitlab-runner-v12.1.0/main.go 2019-07-19 12:13:32.000000000 +0000
+++ gitlab-runner-v12.1.0/main.go 2020-03-04 22:28:31.741878923 +0000
-@@ -11,19 +11,11 @@ import (
+@@ -12,19 +12,11 @@ import (
cli_helpers "gitlab.com/gitlab-org/gitlab-runner/helpers/cli"
"gitlab.com/gitlab-org/gitlab-runner/log"
diff --git a/user/gitlab-runner/fix-multiple-redef-seek.patch b/user/gitlab-runner/fix-multiple-redef-seek.patch
deleted file mode 100644
index e417f84c7..000000000
--- a/user/gitlab-runner/fix-multiple-redef-seek.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -ur a/vendor/golang.org/x/sys/unix/syscall_linux_gccgo_arm.go b/vendor/golang.org/x/sys/unix/syscall_linux_gccgo_arm.go
---- a/vendor/golang.org/x/sys/unix/syscall_linux_gccgo_arm.go 2023-01-04 02:17:18.689781320 +0000
-+++ b/vendor/golang.org/x/sys/unix/syscall_linux_gccgo_arm.go 2023-01-04 02:20:04.283558738 +0000
-@@ -2,7 +2,7 @@
- // Use of this source code is governed by a BSD-style
- // license that can be found in the LICENSE file.
-
--// +build linux,gccgo,arm
-+// +build linux,!gccgo,arm
-
- package unix
-
-@@ -11,6 +11,7 @@
- "unsafe"
- )
-
-+// this file should not be built
- func seek(fd int, offset int64, whence int) (int64, syscall.Errno) {
- var newoffset int64
- offsetLow := uint32(offset & 0xffffffff)
diff --git a/user/gitlab-runner/gccgo.patch b/user/gitlab-runner/gccgo.patch
index bd0b7a3d5..c8704280c 100644
--- a/user/gitlab-runner/gccgo.patch
+++ b/user/gitlab-runner/gccgo.patch
@@ -14,7 +14,7 @@
LATEST_STABLE_TAG := $(shell git -c versionsort.prereleaseSuffix="-rc" -c versionsort.prereleaseSuffix="-RC" tag -l "v*.*.*" | sort -rV | awk '!/rc/' | head -n 1)
export IS_LATEST :=
-@@ -35,14 +34,11 @@ export PATH := $(GOPATH_BIN):$(PATH)
+@@ -36,14 +35,11 @@ export PATH := $(GOPATH_BIN):$(PATH)
BUILD_DIR := $(CURDIR)
TARGET_DIR := $(BUILD_DIR)/out
@@ -31,7 +31,7 @@
# Development Tools
-@@ -136,7 +132,7 @@ build_current: helper-docker build_simpl
+@@ -137,7 +133,7 @@ build_current: helper-docker build_simpl
simple-test: TEST_PKG ?= $(shell go list ./...)
simple-test:
# use env -i to clear parent environment variables for go test
@@ -60,9 +60,9 @@
-var VERSION = "development version"
-var REVISION = "HEAD"
-var BRANCH = "HEAD"
-+var VERSION = "14.0.0"
-+var REVISION = "v14.0.0"
-+var BRANCH = "14-0-stable"
++var VERSION = "15.0.0"
++var REVISION = "v15.0.0"
++var BRANCH = "15-0-stable"
var BUILT = "unknown"
var AppVersion AppVersionInfo
diff --git a/user/gitlab-runner/posix-shell.patch b/user/gitlab-runner/posix-shell.patch
deleted file mode 100644
index 60eab1464..000000000
--- a/user/gitlab-runner/posix-shell.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- gitlab-runner-v12.1.0/shells/bash.go 2019-07-19 12:13:32.000000000 +0000
-+++ gitlab-runner-v12.1.0/shells/bash.go 2020-04-26 23:07:57.303304498 +0000
-@@ -116,12 +116,12 @@ func (b *BashWriter) Variable(variable c
- }
-
- func (b *BashWriter) IfDirectory(path string) {
-- b.Linef("if [[ -d %q ]]; then", path)
-+ b.Linef("if [ -d %q ]; then", path)
- b.Indent()
- }
-
- func (b *BashWriter) IfFile(path string) {
-- b.Linef("if [[ -e %q ]]; then", path)
-+ b.Linef("if [ -e %q ]; then", path)
- b.Indent()
- }
-
-@@ -233,15 +233,15 @@
- func (b *BashWriter) writeEval(w io.Writer) {
-- command := ": | eval " + helpers.ShellEscape(b.String()) + "\n"
-+ command := "(\nexec </dev/null\n" + b.String() + "\n)\n"
- if b.useNewEval {
- command = ": | (eval " + helpers.ShellEscape(b.String()) + ")\n"
- }
-
- _, _ = io.WriteString(w, command)
- }
-
- func (b *BashWriter) writeScript(w io.Writer) {
-- _, _ = io.WriteString(w, "set -eo pipefail\n")
-+ _, _ = io.WriteString(w, "set -e\n")
- _, _ = io.WriteString(w, "set +o noclobber\n")
- b.writeEval(w)
- _, _ = io.WriteString(w, "exit 0\n")
- }
diff --git a/user/gitlab-runner/tests.patch b/user/gitlab-runner/tests.patch
index bad3439df..0762b6b13 100644
--- a/user/gitlab-runner/tests.patch
+++ b/user/gitlab-runner/tests.patch
@@ -1,36 +1,23 @@
--- gitlab-runner-v12.1.0/shells/bash_test.go 2019-07-19 12:13:32.000000000 +0000
+++ gitlab-runner-v12.1.0/shells/bash_test.go 2020-04-27 00:07:06.763360621 +0000
-@@ -12,12 +12,12 @@ func TestBash_CommandShellEscapes(t *tes
- writer := &BashWriter{}
+@@ -16,12 +16,12 @@ func TestBash_CommandShellEscapes(t *tes
+ writer := &BashWriter{useNewEscape: false}
writer.Command("foo", "x&(y)")
- assert.Equal(t, `$'foo' "x&(y)"`+"\n", writer.String())
+ assert.Equal(t, `'foo' "x&(y)"`+"\n", writer.String())
}
- func TestBash_IfCmdShellEscapes(t *testing.T) {
- writer := &BashWriter{}
+ func TestBash_IfCmdShellEscapesLegacy(t *testing.T) {
+ writer := &BashWriter{useNewEscape: false}
writer.IfCmd("foo", "x&(y)")
-- assert.Equal(t, `if $'foo' "x&(y)" >/dev/null 2>/dev/null; then`+"\n", writer.String())
+- assert.Equal(t, `if $'foo' "x&(y)" >/dev/null 2>&1; then`+"\n", writer.String())
+ assert.Equal(t, `if 'foo' "x&(y)" >/dev/null 2>/dev/null; then`+"\n", writer.String())
}
---- gitlab-runner-v12.1.0/helpers/shell_escape_test.go 2019-07-19 12:13:32.000000000 +0000
-+++ gitlab-runner-v12.1.0/helpers/shell_escape_test.go 2020-04-27 00:02:36.213356343 +0000
-@@ -26,8 +26,8 @@ func TestShellEscape(t *testing.T) {
- in string
- out string
- }{
-- {"standard string", "$'standard string'"},
-- {"+\t\n\r&", "$'+\\t\\n\\r&'"},
-+ {"standard string", "'standard string'"},
-+ {"+\t\n\r&", "'+\t\n\r&'"},
- {"", "''"},
- }
-
--- gitlab-runner-v12.1.0/common/build_test.go 2019-07-19 12:13:32.000000000 +0000
+++ gitlab-runner-v12.1.0/common/build_test.go 2020-04-27 00:23:35.173376249 +0000
-@@ -1224,7 +1224,7 @@ func TestWaitForTerminal(t *testing.T) {
+@@ -1255,7 +1255,7 @@ func TestWaitForTerminal(t *testing.T) {
},
jobTimeout: 3600,
waitForTerminalTimeout: time.Hour,