summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Theisen <djt@hxx.in>2018-09-28 00:49:58 -0700
committerDan Theisen <djt@hxx.in>2018-09-28 00:49:58 -0700
commita5867742cf8df0a275e12adb604ce74c8ee9869f (patch)
tree79a913f5786314d8fb12e035638538a4021ff6bc
parentbc360abe6aae2e330b95d4a213d03760e6c90db8 (diff)
downloadpackages-a5867742cf8df0a275e12adb604ce74c8ee9869f.tar.gz
packages-a5867742cf8df0a275e12adb604ce74c8ee9869f.tar.bz2
packages-a5867742cf8df0a275e12adb604ce74c8ee9869f.tar.xz
packages-a5867742cf8df0a275e12adb604ce74c8ee9869f.zip
user/xinput: new package
-rw-r--r--user/xinput/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/xinput/APKBUILD b/user/xinput/APKBUILD
new file mode 100644
index 000000000..2cb5822fe
--- /dev/null
+++ b/user/xinput/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Johannes Matheis <jomat+alpinebuild@jmt.gr>
+# Maintainer: Dan Theisen <djt@hxx.in>
+pkgname=xinput
+pkgver=1.6.2
+pkgrel=0
+pkgdesc="Utility to configure and test XInput devices"
+url="http://xorg.freedesktop.org/"
+arch="all"
+options="!check" # No test suite.
+license="X11"
+makedepends="util-macros libx11-dev libxext-dev libxi-dev libxrandr-dev
+ libxinerama-dev"
+subpackages="$pkgname-doc"
+source="http://www.x.org/archive/individual/app/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="dbef3a87dd47bb8c593f1305bea7978697a12434a4992584e4124d745bb366812366b44fc205159137a3db6f7b8338effd1b90641a194497b19159b9fd91939e xinput-1.6.2.tar.bz2"