summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-05-11 21:52:51 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-05-11 21:52:51 +0000
commita5ce3f8309b0f59316fffa7219bd04f726b08ff5 (patch)
tree0cb02cce8de6e72b59626094b861658f4a7cd558
parent63a154bcdf345cdf15c295e1616dca868ba0a4c3 (diff)
downloadpackages-a5ce3f8309b0f59316fffa7219bd04f726b08ff5.tar.gz
packages-a5ce3f8309b0f59316fffa7219bd04f726b08ff5.tar.bz2
packages-a5ce3f8309b0f59316fffa7219bd04f726b08ff5.tar.xz
packages-a5ce3f8309b0f59316fffa7219bd04f726b08ff5.zip
user/libsigsegv: Port to 32-bit PowerPC
-rw-r--r--user/libsigsegv/APKBUILD7
-rw-r--r--user/libsigsegv/musl-ppc32.patch10
2 files changed, 15 insertions, 2 deletions
diff --git a/user/libsigsegv/APKBUILD b/user/libsigsegv/APKBUILD
index bb21149a3..a99ee7075 100644
--- a/user/libsigsegv/APKBUILD
+++ b/user/libsigsegv/APKBUILD
@@ -11,7 +11,9 @@ license="GPL-2.0+"
depends=""
makedepends=""
subpackages="$pkgname-dev"
-source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz
+ musl-ppc32.patch
+ "
build() {
./configure \
@@ -32,4 +34,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="27986e8aaf4357ed131032aa7c281a5a28c5759530c62bb76f034aea33959547dcaae805e06347a1f532f0488b72fbbbdac4400f74e8d3f2128511526e8a5913 libsigsegv-2.12.tar.gz"
+sha512sums="27986e8aaf4357ed131032aa7c281a5a28c5759530c62bb76f034aea33959547dcaae805e06347a1f532f0488b72fbbbdac4400f74e8d3f2128511526e8a5913 libsigsegv-2.12.tar.gz
+fba3bf8679619d9e363bf42e476960dd73cc9a01915773193d6b6d2ca76ee5240a9284982d00bc40601c6da3210c08eb90e61661404ccaf017144ccc36b25762 musl-ppc32.patch"
diff --git a/user/libsigsegv/musl-ppc32.patch b/user/libsigsegv/musl-ppc32.patch
new file mode 100644
index 000000000..75e10a45f
--- /dev/null
+++ b/user/libsigsegv/musl-ppc32.patch
@@ -0,0 +1,10 @@
+--- libsigsegv-2.12/src/fault-linux-powerpc.h.old 2017-03-04 15:28:15.000000000 +0000
++++ libsigsegv-2.12/src/fault-linux-powerpc.h 2020-05-11 21:49:56.190783142 +0000
+@@ -33,6 +33,6 @@
+ # if 0
+ # define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.regs->gpr[1]
+ # else
+-# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.uc_regs->gregs[1]
++# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.gregs[1]
+ # endif
+ #endif