summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman@gmail.com>2020-06-13 08:29:54 +0000
committerKiyoshi Aman <kiyoshi.aman@gmail.com>2020-06-13 08:36:44 +0000
commita627c2d5b575b97f622728f63140c41dde93828b (patch)
tree00875a34dcee6a9e04fae55142b567d5eeaa5b29
parentb8aef1913e7dc672a1d25d18a83e882590cd1678 (diff)
downloadpackages-a627c2d5b575b97f622728f63140c41dde93828b.tar.gz
packages-a627c2d5b575b97f622728f63140c41dde93828b.tar.bz2
packages-a627c2d5b575b97f622728f63140c41dde93828b.tar.xz
packages-a627c2d5b575b97f622728f63140c41dde93828b.zip
user/uchardet: remove .debug suffix from library
-rw-r--r--user/uchardet/APKBUILD6
-rw-r--r--user/uchardet/no-debug-suffix.patch14
2 files changed, 18 insertions, 2 deletions
diff --git a/user/uchardet/APKBUILD b/user/uchardet/APKBUILD
index 27dabe8ce..c25bc1baf 100644
--- a/user/uchardet/APKBUILD
+++ b/user/uchardet/APKBUILD
@@ -10,7 +10,8 @@ license="MPL-1.1 OR GPL-2.0+ OR LGPL-2.1+"
depends=""
makedepends="cmake"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://www.freedesktop.org/software/uchardet/releases/uchardet-$pkgver.tar.xz"
+source="https://www.freedesktop.org/software/uchardet/releases/uchardet-$pkgver.tar.xz
+ no-debug-suffix.patch"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -35,4 +36,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="ddb7b63dd09c1d9acbe620d86217e583d9aa5340780ab4010ec9faa4fd331498859d5efa7829bf8847da89325accf8f7304b51d410210178fc1ffa6658064a6f uchardet-0.0.7.tar.xz"
+sha512sums="ddb7b63dd09c1d9acbe620d86217e583d9aa5340780ab4010ec9faa4fd331498859d5efa7829bf8847da89325accf8f7304b51d410210178fc1ffa6658064a6f uchardet-0.0.7.tar.xz
+2e6f9d34daa6ba7dab07843368017448a17162d4d55bbc01665d00afa61a36f8b44fd6149706b806c8980632bdf33d073e0a93559d809852e18460551f330ecb no-debug-suffix.patch"
diff --git a/user/uchardet/no-debug-suffix.patch b/user/uchardet/no-debug-suffix.patch
new file mode 100644
index 000000000..f12bb565e
--- /dev/null
+++ b/user/uchardet/no-debug-suffix.patch
@@ -0,0 +1,14 @@
+diff -Nurd uchardet-0.0.7/CMakeLists.txt uchardet-0.0.7.new/CMakeLists.txt
+--- uchardet-0.0.7/CMakeLists.txt 2020-04-23 09:48:58.000000000 +0000
++++ uchardet-0.0.7.new/CMakeLists.txt 2020-06-13 08:26:38.946585352 +0000
+@@ -12,10 +12,6 @@
+ set (UCHARDET_VERSION_MINOR 0)
+ set (UCHARDET_VERSION_REVISION 7)
+
+-if (CMAKE_BUILD_TYPE MATCHES Debug)
+- set (version_suffix .debug)
+-endif (CMAKE_BUILD_TYPE MATCHES Debug)
+-
+ set (
+ UCHARDET_VERSION
+ ${UCHARDET_VERSION_MAJOR}.${UCHARDET_VERSION_MINOR}.${UCHARDET_VERSION_REVISION}${version_suffix}