summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-03-04 20:55:58 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-03-04 20:55:58 -0600
commitaabb2463ecb92c7d5bd52c064d87c86ea3ea5fee (patch)
tree4cf59902bd58000727e9c472005ae54cb96d9659
parentf7e640d6f699dca32efc43aedd611286c34a6613 (diff)
downloadpackages-aabb2463ecb92c7d5bd52c064d87c86ea3ea5fee.tar.gz
packages-aabb2463ecb92c7d5bd52c064d87c86ea3ea5fee.tar.bz2
packages-aabb2463ecb92c7d5bd52c064d87c86ea3ea5fee.tar.xz
packages-aabb2463ecb92c7d5bd52c064d87c86ea3ea5fee.zip
user/rfkill: don't use Git for version
-rw-r--r--user/rfkill/APKBUILD12
-rw-r--r--user/rfkill/dont-use-git.patch24
2 files changed, 31 insertions, 5 deletions
diff --git a/user/rfkill/APKBUILD b/user/rfkill/APKBUILD
index 3e2cad165..9f9889e9a 100644
--- a/user/rfkill/APKBUILD
+++ b/user/rfkill/APKBUILD
@@ -2,17 +2,18 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=rfkill
pkgver=0.5
-pkgrel=0
+pkgrel=1
pkgdesc="Tool to query the state of the rfkill switches and buttons"
url="https://wireless.wiki.kernel.org/en/users/Documentation/rfkill"
arch="all"
-license="GPL"
+options="!check" # No test suite.
+license="MIT"
depends=""
makedepends=""
install=""
-options="!check"
subpackages="$pkgname-doc"
-source="https://www.kernel.org/pub/software/network/rfkill/rfkill-$pkgver.tar.xz"
+source="https://www.kernel.org/pub/software/network/rfkill/rfkill-$pkgver.tar.xz
+ dont-use-git.patch"
build() {
cd "$builddir"
@@ -24,4 +25,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="6ad4d28e7bf7ec69ec6a600cd774b7b3c60e85849ae3fca0f5509ed6a283ed5656d37cfd770df45ff1ceca59edd814807d116b30e199fca303baf496441419d7 rfkill-0.5.tar.xz"
+sha512sums="6ad4d28e7bf7ec69ec6a600cd774b7b3c60e85849ae3fca0f5509ed6a283ed5656d37cfd770df45ff1ceca59edd814807d116b30e199fca303baf496441419d7 rfkill-0.5.tar.xz
+635d948b4addfb418a3dd1a0f2482b15e5dae7e161f3fc1a430a2052d2aeb4e0d0a8c7663e27d1f8741920a497f0e36bac949f14544f5157f037315822a08d04 dont-use-git.patch"
diff --git a/user/rfkill/dont-use-git.patch b/user/rfkill/dont-use-git.patch
new file mode 100644
index 000000000..d673adc85
--- /dev/null
+++ b/user/rfkill/dont-use-git.patch
@@ -0,0 +1,24 @@
+This is required because packages.git is a git repo.
+
+--- rfkill-0.5/version.sh 2013-05-03 11:24:22.000000000 +0000
++++ rfkill-0.5/version.sh 2018-03-05 02:54:41.510838411 +0000
+@@ -12,19 +12,6 @@
+
+ if test "x$SUFFIX" != 'x'; then
+ v="$VERSION$SUFFIX"
+-elif head=`git rev-parse --verify HEAD 2>/dev/null`; then
+- git update-index --refresh --unmerged > /dev/null
+- descr=$(git describe 2>/dev/null || echo "v$VERSION")
+-
+- # on git builds check that the version number above
+- # is correct...
+- [ "${descr%%-*}" = "v$VERSION" ] || exit 2
+-
+- echo -n 'const char rfkill_version[] = "' > "$OUT"
+- v="${descr#v}"
+- if git diff-index --name-only HEAD | read dummy ; then
+- v="$v"-dirty
+- fi
+ else
+ v="$VERSION"
+ fi