summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-05-29 23:48:10 -0500
committerZach van Rijn <me@zv.io>2022-10-21 18:34:01 -0500
commitad5db52dcda860a0d94290a4195a894f50403231 (patch)
tree0330b6aa516bd65b711520b986bd043b3f5f30e9
parent823f7c73c8d6f12d66e0d4bb5c5c197d7409c5b3 (diff)
downloadpackages-ad5db52dcda860a0d94290a4195a894f50403231.tar.gz
packages-ad5db52dcda860a0d94290a4195a894f50403231.tar.bz2
packages-ad5db52dcda860a0d94290a4195a894f50403231.tar.xz
packages-ad5db52dcda860a0d94290a4195a894f50403231.zip
user/mesa: Update to 20.3.5
Run-tested on PPC64. Intermediate step for full update.
-rw-r--r--user/mesa/APKBUILD19
-rw-r--r--user/mesa/musl-fix-includes.patch14
-rw-r--r--user/mesa/no-tls.patch15
-rw-r--r--user/mesa/time64.patch34
4 files changed, 16 insertions, 66 deletions
diff --git a/user/mesa/APKBUILD b/user/mesa/APKBUILD
index 7af2e17cd..8eb3a077b 100644
--- a/user/mesa/APKBUILD
+++ b/user/mesa/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=mesa
-pkgver=19.3.4
+pkgver=20.3.5
_llvmver=8
pkgrel=0
pkgdesc="Mesa DRI OpenGL library"
@@ -14,7 +14,8 @@ depends_dev="libdrm-dev libxcb-dev libxdamage-dev libxext-dev libxshmfence-dev
makedepends="$depends_dev bison eudev-dev expat-dev flex libelf-dev
libva-dev libvdpau-dev libx11-dev libxfixes-dev libxrandr-dev libxt-dev
libxv-dev libxvmc-dev libxxf86vm-dev llvm$_llvmver-dev makedepend meson
- ninja python3 py3-libxml2 py3-mako zlib-dev"
+ ninja python3 py3-libxml2 py3-mako wayland-dev wayland-protocols
+ zlib-dev zstd-dev"
subpackages="$pkgname-dev $pkgname-dri
$pkgname-glapi $pkgname-egl $pkgname-gl $pkgname-gles
$pkgname-xatracker $pkgname-osmesa $pkgname-gbm"
@@ -24,14 +25,12 @@ source="https://mesa.freedesktop.org/archive/mesa-$pkgver.tar.xz
big-endian-flipping.patch
intel-vulkan.patch
musl-fixes.patch
- musl-fix-includes.patch
no-tls.patch
- time64.patch
"
_dri_driverdir=/usr/lib/xorg/modules/dri
_dri_drivers="r200,nouveau"
-_gallium_drivers="r300,r600,radeonsi,nouveau,freedreno,swrast,virgl"
+_gallium_drivers="r300,r600,radeonsi,nouveau,swrast,virgl"
_vulkan_drivers="amd"
case "$CARCH" in
@@ -47,7 +46,7 @@ aarch64 | arm*)
esac
;;
ppc64)
- _arch_conf="-Dpower8=false"
+ _arch_conf="-Dpower8=disabled"
;;
esac
@@ -55,7 +54,7 @@ build() {
meson \
-Dprefix=/usr \
-Ddri-drivers-path=$_dri_driverdir \
- -Dplatforms=x11,drm,surfaceless \
+ -Dplatforms=x11,wayland \
-Ddri-drivers=$_dri_drivers \
-Dgallium-drivers=$_gallium_drivers \
-Dvulkan-drivers=$_vulkan_drivers \
@@ -153,11 +152,9 @@ dri() {
mv "$pkgdir"/usr/share/vulkan/icd.d "$subpkgdir"/usr/share/vulkan/
}
-sha512sums="2bbb3dc8f1d839f11fe12cc959393cd69607fa6714b2166b80299e0559d2d3b0ac38ed4e15ac3e5f472264eb24536d1901d350f7409f3a7e00d6f4ccbb2312fb mesa-19.3.4.tar.xz
+sha512sums="481e710ed80d8f215a8d541cfe51b960862c2403c2b9e7e6932c8236b8decb5d478871d6c73559d6d795ada143803764f3a93b2329588c80f62e2e5ec98c78a9 mesa-20.3.5.tar.xz
245d0d64d858dfadeeb544f31f7d0bb6ecb746a7fd5ec99755d679ae1a1eef4198d66473fb24d333eb6786bb8657012771e8285d67f165dc61a031df801947aa amdgpu-pthread-header.patch
3417e5c6d7ec564178e1d72431042b0a6ba659321f13a3dda81eda5fa0f2c8bc7c6972cb8266aea84ab05976ffb161659e9988c50ecc418e8bc1e1ce8f93a65f big-endian-flipping.patch
ba954ea9aa49e5cdfec08f310f41abf09e01a2a889a09b6c32a154b750d3ebb2bfb5a9b7d244c06d26442688aeeb7f212f5f3c98c6db69f878098a49d476ff70 intel-vulkan.patch
9f7a050f09571a2b17098d495b82e2e85b293fb7285e7d6d7c3c48cd4220a1bdcc61a7321ba78dd14860939ecabe7e89b32d6110f3728f793273e1e26b78a553 musl-fixes.patch
-c7d91a660a033df91fac9c557039efc8669f0c26b2d35997d50753938b70d1af0bd110dcab3f8236eafab7d4be5dd7cd128a3e057e67e7e6a38a73fd6a7ef62e musl-fix-includes.patch
-56e829b0570cf5215c191330a5162356b77eeb555eb8127e30da57bdff9d369c1bb3de3bd7ee36233d6d610c0cec81773879da05cc0b391e06ff4d7507bef8a8 no-tls.patch
-0aad2fdc56ea8825533746ee4c2c803734f871e04da13ddd461b2de36716ba52e345e745a6861ffae62efacf6b64f629187ddda3c01e3d880ce20c0ac551dccb time64.patch"
+d059ef74bc2b16aadd2737aa19810da82e5ff37d897faf231f9b028e0d490014b493e779f92503ccf22636c0488ac18faaa25b1f9ff324fc62fbe0d6d844a2bd no-tls.patch"
diff --git a/user/mesa/musl-fix-includes.patch b/user/mesa/musl-fix-includes.patch
deleted file mode 100644
index 2f6cc1d13..000000000
--- a/user/mesa/musl-fix-includes.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/src/util/rand_xor.c b/src/util/rand_xor.c
-index de05fa6..016703c 100644
---- a/src/util/rand_xor.c
-+++ b/src/util/rand_xor.c
-@@ -24,6 +24,9 @@
-
- #if defined(__linux__)
- #include <sys/file.h>
-+#include <sys/types.h>
-+#include <sys/stat.h>
-+#include <fcntl.h>
- #include <unistd.h>
- #else
- #include <time.h>
diff --git a/user/mesa/no-tls.patch b/user/mesa/no-tls.patch
index b5e0b3adb..a6b989e87 100644
--- a/user/mesa/no-tls.patch
+++ b/user/mesa/no-tls.patch
@@ -1,14 +1,15 @@
---- mesa-19.3.1/meson.build.old 2019-12-18 18:36:00.000000000 +0000
-+++ mesa-19.3.1/meson.build 2020-01-26 05:11:44.774286868 +0000
-@@ -386,11 +386,6 @@
- endif
+--- mesa-20.3.5/meson.build.old 2021-03-24 14:10:48.523084000 -0500
++++ mesa-20.3.5/meson.build 2022-05-29 23:43:09.679306824 -0500
+@@ -434,12 +434,7 @@
+ with_egl = false
endif
-# Android uses emutls for versions <= P/28. For USE_ELF_TLS we need ELF TLS.
--if host_machine.system() != 'windows' and (not with_platform_android or get_option('platform-sdk-version') >= 29)
+ use_elf_tls = false
+-if not ['windows', 'freebsd', 'openbsd'].contains(host_machine.system()) and (not with_platform_android or get_option('platform-sdk-version') >= 29)
- pre_args += '-DUSE_ELF_TLS'
+- use_elf_tls = true
-endif
--
+
if with_glx != 'disabled'
if not (with_platform_x11 and with_any_opengl)
- error('Cannot build GLX support without X11 platform support and at least one OpenGL API')
diff --git a/user/mesa/time64.patch b/user/mesa/time64.patch
deleted file mode 100644
index 7e7894a9d..000000000
--- a/user/mesa/time64.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- mesa-19.3.1/src/gallium/drivers/vc4/vc4_bufmgr.c.old 2019-12-18 18:36:00.000000000 +0000
-+++ mesa-19.3.1/src/gallium/drivers/vc4/vc4_bufmgr.c 2020-01-20 19:26:36.470000000 +0000
-@@ -107,8 +107,8 @@
-
- struct timespec time;
- clock_gettime(CLOCK_MONOTONIC, &time);
-- fprintf(stderr, " now: %ld\n",
-- time.tv_sec);
-+ fprintf(stderr, " now: %"PRId64"\n",
-+ (int64_t)time.tv_sec);
- }
- }
-
---- mesa-19.3.1/src/gallium/drivers/v3d/v3d_bufmgr.c.old 2019-12-18 18:36:00.000000000 +0000
-+++ mesa-19.3.1/src/gallium/drivers/v3d/v3d_bufmgr.c 2020-01-20 19:28:02.600000000 +0000
-@@ -23,6 +23,7 @@
-
- #include <errno.h>
- #include <err.h>
-+#include <inttypes.h>
- #include <sys/mman.h>
- #include <fcntl.h>
- #include <xf86drm.h>
-@@ -80,8 +81,8 @@
-
- struct timespec time;
- clock_gettime(CLOCK_MONOTONIC, &time);
-- fprintf(stderr, " now: %ld\n",
-- time.tv_sec);
-+ fprintf(stderr, " now: %"PRId64"\n",
-+ (int64_t)time.tv_sec);
- }
- }
-