summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-14 18:32:32 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-14 18:32:32 -0500
commitb2ca694512b2184aa2a6a9082b5cfa10409e27d9 (patch)
tree0b17d57de756c64610eaf6b9b4982cbfb0c07e32
parentdd4a1428a88f298bcc833d9f831fa800c788b497 (diff)
downloadpackages-b2ca694512b2184aa2a6a9082b5cfa10409e27d9.tar.gz
packages-b2ca694512b2184aa2a6a9082b5cfa10409e27d9.tar.bz2
packages-b2ca694512b2184aa2a6a9082b5cfa10409e27d9.tar.xz
packages-b2ca694512b2184aa2a6a9082b5cfa10409e27d9.zip
user/libbytesize: add beleaguered package
-rw-r--r--user/libbytesize/APKBUILD50
-rw-r--r--user/libbytesize/no-msgcat.patch51
2 files changed, 101 insertions, 0 deletions
diff --git a/user/libbytesize/APKBUILD b/user/libbytesize/APKBUILD
new file mode 100644
index 000000000..e9c693deb
--- /dev/null
+++ b/user/libbytesize/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=libbytesize
+pkgver=1.3
+pkgrel=0
+pkgdesc="Library for working with sizes in bytes"
+url="https://github.com/storaged-project/libbytesize/"
+arch="all"
+options="!check" # Requires locale(1).
+license="LGPL-2.1+"
+makedepends="gmp-dev mpfr-dev python3"
+subpackages="$pkgname-dev $pkgname-lang py3-bytesize:py:noarch"
+source="https://github.com/storaged-project/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz
+ no-msgcat.patch"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --without-python2
+ # XXX We do not have a msgfilter app in gettext-tiny.
+ # This would be required to ship a Serbian translation.
+ rm po/sr*
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+py() {
+ pkgdesc="$pkgdesc (Python bindings)"
+ depends="py3-six"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+
+sha512sums="a8e5b5d59d0a97ae52a2c0f437c4d7fd8afc8249762be99027e3beeadc6c54ad52a09c1d30e66466b99496fcf3419fa799d0fcccf61c0661b3e9cff48d0054af libbytesize-1.3.tar.gz
+5f8b46c257553672b7c2501bae99ff44594b91bfcf3f1ee209a390a8cdda693616e8207a99cea2e1263093324807a307dac9e643d1482e14f9ba604f51a05d6d no-msgcat.patch"
diff --git a/user/libbytesize/no-msgcat.patch b/user/libbytesize/no-msgcat.patch
new file mode 100644
index 000000000..ddff7ff04
--- /dev/null
+++ b/user/libbytesize/no-msgcat.patch
@@ -0,0 +1,51 @@
+--- libbytesize-1.3/configure.old 2018-04-19 11:20:01.000000000 +0000
++++ libbytesize-1.3/configure 2018-07-14 22:58:34.300000000 +0000
+@@ -2975,47 +2975,7 @@
+ fi
+
+
+-# Extract the first word of "msgcat", so it can be a program name with args.
+-set dummy msgcat; ac_word=$2
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+-$as_echo_n "checking for $ac_word... " >&6; }
+-if ${ac_cv_path_MSGCAT+:} false; then :
+- $as_echo_n "(cached) " >&6
+-else
+- case $MSGCAT in
+- [\\/]* | ?:[\\/]*)
+- ac_cv_path_MSGCAT="$MSGCAT" # Let the user override the test with a path.
+- ;;
+- *)
+- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $PATH
+-do
+- IFS=$as_save_IFS
+- test -z "$as_dir" && as_dir=.
+- for ac_exec_ext in '' $ac_executable_extensions; do
+- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+- ac_cv_path_MSGCAT="$as_dir/$ac_word$ac_exec_ext"
+- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+- break 2
+- fi
+-done
+- done
+-IFS=$as_save_IFS
+-
+- ;;
+-esac
+-fi
+-MSGCAT=$ac_cv_path_MSGCAT
+-if test -n "$MSGCAT"; then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $MSGCAT" >&5
+-$as_echo "$MSGCAT" >&6; }
+-else
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; }
+-fi
+-
+-
+-if test -z "$XGETTEXT" -o -z "$MSGFMT" -o -z "$MSGMERGE" -o -z "$MSGCAT"; then :
++if test -z "$XGETTEXT" -o -z "$MSGFMT" -o -z "$MSGMERGE"; then :
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
+ $as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
+ as_fn_error $? "gettext not found