summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-24 01:37:19 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-24 01:37:19 -0500
commitb34e6fe698af4901a2a662cc0ce671afa755e121 (patch)
treec44b43797a7bc1d773b38651f5a7a0cd0805dbd5
parent5af360c54948e9d769ea50ef6b872baad846b946 (diff)
downloadpackages-b34e6fe698af4901a2a662cc0ce671afa755e121.tar.gz
packages-b34e6fe698af4901a2a662cc0ce671afa755e121.tar.bz2
packages-b34e6fe698af4901a2a662cc0ce671afa755e121.tar.xz
packages-b34e6fe698af4901a2a662cc0ce671afa755e121.zip
system/yaml: pull in for ruby
-rw-r--r--system/yaml/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/system/yaml/APKBUILD b/system/yaml/APKBUILD
new file mode 100644
index 000000000..5499c5e51
--- /dev/null
+++ b/system/yaml/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=yaml
+pkgver=0.1.7
+pkgrel=0
+pkgdesc="YAML 1.1 parser and emitter written in C"
+url="http://pyyaml.org/wiki/LibYAML"
+arch="all"
+license="MIT"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev"
+source="http://pyyaml.org/download/libyaml/yaml-$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="1ee5007dd10db137b5ee80f8117f07390ec04af98d087a5f5475dd2b38d87c699b79ab1676e6c7bfa263323fcdf8edd69fada2b0b7f9c57bef4e46cd65f1e975 yaml-0.1.7.tar.gz"