summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-02 23:23:18 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-02 23:23:18 +0000
commitc33214f0f31529c15696bee344e08abb1446e996 (patch)
tree5f093429d177905cbdaaec66aeaa535a4e8e304f
parent33b95bdbff212f69a303f61b9235839c127cc17d (diff)
downloadpackages-c33214f0f31529c15696bee344e08abb1446e996.tar.gz
packages-c33214f0f31529c15696bee344e08abb1446e996.tar.bz2
packages-c33214f0f31529c15696bee344e08abb1446e996.tar.xz
packages-c33214f0f31529c15696bee344e08abb1446e996.zip
user/*: Modernise / fix syntax / deps
-rw-r--r--user/libaacs/APKBUILD5
-rw-r--r--user/libavc1394/APKBUILD12
-rw-r--r--user/libbluray/APKBUILD1
-rw-r--r--user/libdc1394/APKBUILD2
-rw-r--r--user/libdca/APKBUILD4
-rw-r--r--user/libmatroska/APKBUILD7
-rw-r--r--user/libmpeg2/APKBUILD6
-rw-r--r--user/sysfsutils/APKBUILD5
8 files changed, 15 insertions, 27 deletions
diff --git a/user/libaacs/APKBUILD b/user/libaacs/APKBUILD
index 6278e5c9f..11bb90c18 100644
--- a/user/libaacs/APKBUILD
+++ b/user/libaacs/APKBUILD
@@ -7,13 +7,12 @@ pkgdesc="Library to decrypt Advanced Access Content System content"
url="https://www.videolan.org/developers/libaacs.html"
arch="all"
license="LGPL-2.1+"
+depends=""
makedepends="bison flex libgcrypt-dev libgpg-error-dev"
subpackages="$pkgname-dev"
source="https://download.videolan.org/pub/videolan/libaacs/$pkgver/libaacs-$pkgver.tar.bz2"
build() {
- cd "$builddir"
-
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -26,12 +25,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/libavc1394/APKBUILD b/user/libavc1394/APKBUILD
index 5fd7c7ef6..a76d47301 100644
--- a/user/libavc1394/APKBUILD
+++ b/user/libavc1394/APKBUILD
@@ -8,22 +8,20 @@ url="https://sourceforge.net/projects/libavc1394/"
arch="all"
license="LGPL-2.1+"
depends=""
-makedepends="libraw1394-dev libtool automake autoconf"
-[ "$CLIBC" != "eglibc" ] && makedepends="$makedepends argp-standalone"
+makedepends="libraw1394-dev libtool automake autoconf argp-standalone"
subpackages="$pkgname-dev $pkgname-doc"
source="https://downloads.sourceforge.net/libavc1394/libavc1394-$pkgver.tar.gz
automake.patch
- argp.patch"
+ argp.patch
+ "
prepare() {
- cd "$builddir"
- update_config_sub
default_prepare
+ update_config_sub
libtoolize && aclocal && autoconf && automake --add-missing
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -36,12 +34,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/libbluray/APKBUILD b/user/libbluray/APKBUILD
index 99d2d0002..4357d589c 100644
--- a/user/libbluray/APKBUILD
+++ b/user/libbluray/APKBUILD
@@ -8,6 +8,7 @@ url="https://www.videolan.org/developers/libbluray.html"
arch="all"
options="!check" # Test requires an actual BD-ROM to play
license="LGPL-2.1+"
+depends=""
makedepends="fontconfig-dev libxml2-dev"
subpackages="$pkgname-dev"
source="https://download.videolan.org/pub/videolan/libbluray/$pkgver/libbluray-$pkgver.tar.bz2"
diff --git a/user/libdc1394/APKBUILD b/user/libdc1394/APKBUILD
index d36d55a47..138f14cf7 100644
--- a/user/libdc1394/APKBUILD
+++ b/user/libdc1394/APKBUILD
@@ -15,7 +15,6 @@ subpackages="$pkgname-dev $pkgname-doc"
source="https://downloads.sourceforge.net/project/libdc1394/libdc1394-2/$pkgver/libdc1394-$pkgver.tar.gz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -28,7 +27,6 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/libdca/APKBUILD b/user/libdca/APKBUILD
index 6ee2be1d5..aa4925405 100644
--- a/user/libdca/APKBUILD
+++ b/user/libdca/APKBUILD
@@ -8,11 +8,11 @@ url="https://www.videolan.org/developers/libdca.html"
arch="all"
license="GPL-2.0+"
depends=""
+makedepends=""
subpackages="$pkgname-dev $pkgname-doc"
source="https://download.videolan.org/pub/videolan/libdca/$pkgver/libdca-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -24,12 +24,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/libmatroska/APKBUILD b/user/libmatroska/APKBUILD
index 6a8ea1f9d..076e9a9e2 100644
--- a/user/libmatroska/APKBUILD
+++ b/user/libmatroska/APKBUILD
@@ -8,24 +8,23 @@ url="https://www.matroska.org/"
arch="all"
options="!check" # No test suite.
license="LGPL-2.1+"
-makedepends="libebml-dev>=1.3.3"
+depends=""
+makedepends="cmake libebml-dev>=1.3.3"
subpackages="$pkgname-dev"
source="https://dl.matroska.org/downloads/$pkgname/$pkgname-$pkgver.tar.xz"
build() {
- cd "$builddir"
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
- -DCMAKE_C_FLAGS="$CFLAGS"
+ -DCMAKE_C_FLAGS="$CFLAGS" .
make
}
package() {
- cd "$builddir"
make install DESTDIR="$pkgdir"
}
diff --git a/user/libmpeg2/APKBUILD b/user/libmpeg2/APKBUILD
index f24035f54..b2a4a6056 100644
--- a/user/libmpeg2/APKBUILD
+++ b/user/libmpeg2/APKBUILD
@@ -6,8 +6,10 @@ pkgdesc="Library for decoding MPEG-1 and MPEG-2 video streams"
url="http://libmpeg2.sourceforge.net/"
arch="all"
license="GPL-2.0+ AND LGPL-2.0+"
+depends=""
+makedepends="libx11-dev libice-dev libsm-dev libxext-dev libxv-dev
+ autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-doc mpeg2dec"
-makedepends="libx11-dev libice-dev libsm-dev libxext-dev libxv-dev"
source="http://distfiles.gentoo.org/distfiles/libmpeg2-$pkgver.tar.gz
arm-private-symbols.patch
arm-textrel.patch
@@ -15,8 +17,8 @@ source="http://distfiles.gentoo.org/distfiles/libmpeg2-$pkgver.tar.gz
"
prepare() {
- update_config_sub
default_prepare
+ update_config_sub
autoreconf -vif
}
diff --git a/user/sysfsutils/APKBUILD b/user/sysfsutils/APKBUILD
index da5f74618..99fde3f4e 100644
--- a/user/sysfsutils/APKBUILD
+++ b/user/sysfsutils/APKBUILD
@@ -13,13 +13,11 @@ subpackages="$pkgname-dev $pkgname-doc"
source="https://downloads.sourceforge.net/sourceforge/linux-diag/$pkgname-$pkgver.tar.gz"
prepare() {
- cd "$builddir"
- update_config_sub
default_prepare
+ update_config_sub
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -29,7 +27,6 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir"/ install
}