summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzlg <zlg@zlg.space>2018-11-21 03:15:38 -0800
committerzlg <zlg@zlg.space>2018-11-21 03:35:28 -0800
commitc5e77c17477cef73e709abbf92a4ca788088fe11 (patch)
tree3d478da039d8e0576a23b76f4392e437c51845e7
parent6eea1b3e4abad6a00e44635f15d5f0dd98b9b957 (diff)
downloadpackages-c5e77c17477cef73e709abbf92a4ca788088fe11.tar.gz
packages-c5e77c17477cef73e709abbf92a4ca788088fe11.tar.bz2
packages-c5e77c17477cef73e709abbf92a4ca788088fe11.tar.xz
packages-c5e77c17477cef73e709abbf92a4ca788088fe11.zip
user/py3-cryptography: new package
-rw-r--r--user/py3-cryptography/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/user/py3-cryptography/APKBUILD b/user/py3-cryptography/APKBUILD
new file mode 100644
index 000000000..9305614b5
--- /dev/null
+++ b/user/py3-cryptography/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: August Klein <amatcoder@gmail.com>
+# Maintainer: zlg <zlg+adelie@zlg.space>
+pkgname=py3-cryptography
+_pkgname=${pkgname#py3-}
+pkgver=2.3.1
+pkgrel=0
+pkgdesc="A package which provides cryptographic recipes and primitives"
+url="https://pypi.python.org/pypi/cryptography"
+arch="all"
+options="!check" # tests want hypothesis; deep rabbit hole
+license="Apache-2.0 OR BSD"
+depends="py3-cffi py3-idna py3-asn1crypto py3-six"
+makedepends="python3-dev libffi-dev openssl-dev"
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="384581238b5669dbf31fd1b1385ec2ff9c6d76e2b7612efb15f255e17a11a38474f84668e62ceaa39a146260f46cac743575c0a8ffedc1e40c7b2f90d7cb00b1 cryptography-2.3.1.tar.gz"