summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-20 23:59:43 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-20 23:59:43 +0000
commitc6e4237951b3670dc3cf0afd9ddd406d5b1ef792 (patch)
tree553f93fc7657568f8a723abbcfff2a63a55b329b
parent51befc595835b6c213d5322b6746fbf68b552ad3 (diff)
downloadpackages-c6e4237951b3670dc3cf0afd9ddd406d5b1ef792.tar.gz
packages-c6e4237951b3670dc3cf0afd9ddd406d5b1ef792.tar.bz2
packages-c6e4237951b3670dc3cf0afd9ddd406d5b1ef792.tar.xz
packages-c6e4237951b3670dc3cf0afd9ddd406d5b1ef792.zip
system/a*: modernise, fix descriptions
-rw-r--r--system/adelie-keys/APKBUILD2
-rw-r--r--system/apk-tools/APKBUILD8
-rw-r--r--system/argon2/APKBUILD2
-rw-r--r--system/asciidoctor/APKBUILD3
-rw-r--r--system/at/APKBUILD2
-rw-r--r--system/atf/APKBUILD5
-rw-r--r--system/autoconf/APKBUILD3
-rw-r--r--system/automake/APKBUILD3
8 files changed, 9 insertions, 19 deletions
diff --git a/system/adelie-keys/APKBUILD b/system/adelie-keys/APKBUILD
index 3bdc5295d..ba7143df3 100644
--- a/system/adelie-keys/APKBUILD
+++ b/system/adelie-keys/APKBUILD
@@ -7,6 +7,8 @@ url="https://www.adelielinux.org/"
arch="noarch"
options="!check" # No test suite
license="Public-Domain" # there is no way to copyright key files
+depends=""
+makedepends=""
source="packages@adelielinux.org.pub"
package() {
diff --git a/system/apk-tools/APKBUILD b/system/apk-tools/APKBUILD
index c20759d7c..aa4f95f5d 100644
--- a/system/apk-tools/APKBUILD
+++ b/system/apk-tools/APKBUILD
@@ -21,7 +21,6 @@ source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz
prepare() {
default_prepare
- cd "$builddir"
sed -i -e 's:-Werror::' Make.rules
echo "FULL_VERSION=$pkgver-r$pkgrel" > config.mk
echo "LUAAPK=" >> config.mk
@@ -29,18 +28,15 @@ prepare() {
}
build() {
- cd "$builddir"
make
make static
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -d "$pkgdir"/var/lib/apk \
"$pkgdir"/var/cache/misc \
@@ -55,8 +51,8 @@ static() {
install -Dm755 "$srcdir"/$pkgname-$pkgver/src/apk.static \
"$subpkgdir"/sbin/apk.static
- # lets sign the static binary so it can be vefified from distros
- # that does not have apk-tools
+ # Sign the static binary so it can be vefified from distros
+ # that do not have apk-tools
local abuild_conf="${ABUILD_CONF:-"/etc/abuild.conf"}"
local abuild_home="${ABUILD_USERDIR:-"$HOME/.abuild"}"
local abuild_userconf="${ABUILD_USERCONF:-"$abuild_home/abuild.conf"}"
diff --git a/system/argon2/APKBUILD b/system/argon2/APKBUILD
index 7a7331221..42d459e1f 100644
--- a/system/argon2/APKBUILD
+++ b/system/argon2/APKBUILD
@@ -5,7 +5,7 @@ pkgname=argon2
_pkgname=phc-winner-argon2
pkgver=20190702
pkgrel=0
-pkgdesc="Password hashing function Argon2"
+pkgdesc="Password hashing library"
url="https://github.com/P-H-C/phc-winner-argon2"
arch="all"
license="Apache-2.0 AND CC0-1.0"
diff --git a/system/asciidoctor/APKBUILD b/system/asciidoctor/APKBUILD
index 3b05ab44d..760f82d81 100644
--- a/system/asciidoctor/APKBUILD
+++ b/system/asciidoctor/APKBUILD
@@ -3,12 +3,13 @@
pkgname=asciidoctor
pkgver=1.5.8
pkgrel=0
-pkgdesc="A text processor for converting AsciiDoc markup into HTML 5, DocBook 4.5 and other formats"
+pkgdesc="An implementation of AsciiDoc in Ruby"
url="https://rubygems.org/gems/$pkgname"
arch="noarch"
options="!check" # can't test in this packaging format; package differently
license="MIT"
depends="ruby"
+makedepends=""
source="https://rubygems.org/downloads/$pkgname-$pkgver.gem"
package() {
diff --git a/system/at/APKBUILD b/system/at/APKBUILD
index a50d7fb77..833026123 100644
--- a/system/at/APKBUILD
+++ b/system/at/APKBUILD
@@ -4,7 +4,7 @@ pkgname=at
pkgver=3.1.23
pkgrel=2
pkgdesc="Delayed job execution and batch processing daemon"
-url="https://packages.qa.debian.org/a/at.html"
+url="http://blog.calhariz.com/tag/at"
arch="all"
options="!check suid" # No test suite.
license="GPL-2.0+"
diff --git a/system/atf/APKBUILD b/system/atf/APKBUILD
index 5b4f82a92..1c8fc1a64 100644
--- a/system/atf/APKBUILD
+++ b/system/atf/APKBUILD
@@ -2,7 +2,7 @@
pkgname=atf
pkgver=0.21
pkgrel=1
-pkgdesc="libraries to write tests in C, C++ and shell"
+pkgdesc="Automated Testing Framework"
url="https://github.com/jmmv/atf"
arch="all"
license="BSD-2-Clause AND BSD-3-Clause"
@@ -13,7 +13,6 @@ source="https://github.com/jmmv/atf/releases/download/atf-$pkgver/atf-$pkgver.ta
builddir="$srcdir/atf-$pkgver"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,12 +24,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/system/autoconf/APKBUILD b/system/autoconf/APKBUILD
index 262087d79..02f6deb7d 100644
--- a/system/autoconf/APKBUILD
+++ b/system/autoconf/APKBUILD
@@ -18,7 +18,6 @@ prepare() {
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,7 +26,6 @@ build() {
}
check() {
- cd "$builddir"
# 38 fails with new perl; 501 fails with new libtool
# 351 known broken since 2012:
# https://lists.gnu.org/archive/html/bug-autoconf/2013-01/msg00000.html
@@ -35,7 +33,6 @@ check() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
rm -f "$pkgdir"/usr/share/info/dir
# conflict with bintuils
diff --git a/system/automake/APKBUILD b/system/automake/APKBUILD
index 6612e9e19..3684a9965 100644
--- a/system/automake/APKBUILD
+++ b/system/automake/APKBUILD
@@ -14,7 +14,6 @@ subpackages="$pkgname-doc"
source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -23,12 +22,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR=$pkgdir install
}