summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-26 06:14:04 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-26 06:14:04 -0500
commitcb5c29d47632246ecd22bdb4982e181c338f0322 (patch)
treee8ba0415be3f90239a83e8216d2df5ca7908797a
parentf026b311d1682558a5a6d84df7e95f260d8110a5 (diff)
downloadpackages-cb5c29d47632246ecd22bdb4982e181c338f0322.tar.gz
packages-cb5c29d47632246ecd22bdb4982e181c338f0322.tar.bz2
packages-cb5c29d47632246ecd22bdb4982e181c338f0322.tar.xz
packages-cb5c29d47632246ecd22bdb4982e181c338f0322.zip
system/perl-cpanel-json-xs: add for perl-json-maybexs
-rw-r--r--system/perl-cpanel-json-xs/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/system/perl-cpanel-json-xs/APKBUILD b/system/perl-cpanel-json-xs/APKBUILD
new file mode 100644
index 000000000..801c2e226
--- /dev/null
+++ b/system/perl-cpanel-json-xs/APKBUILD
@@ -0,0 +1,43 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-cpanel-json-xs
+_pkgreal=Cpanel-JSON-XS
+pkgver=4.04
+pkgrel=0
+pkgdesc="cPanel's fork of JSON::XS, fast and correct serialising"
+url="http://search.cpan.org/dist/Cpanel-JSON-XS/"
+arch="all"
+license="GPL-2.0-only OR Artistic-1.0-Perl"
+cpandepends=""
+cpanmakedepends="perl-json perl-test-leaktrace"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/R/RU/RURBAN/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="6b2479ee89f2b8c79ef979cecbdb6f29c28ee37ab530eabc9070728ba37063be3c5836571bea84d537dc93f8586cca71fd3bdca5e420c1d6a2eabf2547ca1db7 Cpanel-JSON-XS-4.04.tar.gz"