summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-20 18:27:01 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-20 18:27:01 -0500
commitd08e2b532af226292e1711373c1aec7d00f753ad (patch)
tree9843a19e61486282b50aeeceae860941a735146a
parent64d6b403ae0ac25ea65d445f72f7c58b5be677ef (diff)
downloadpackages-d08e2b532af226292e1711373c1aec7d00f753ad.tar.gz
packages-d08e2b532af226292e1711373c1aec7d00f753ad.tar.bz2
packages-d08e2b532af226292e1711373c1aec7d00f753ad.tar.xz
packages-d08e2b532af226292e1711373c1aec7d00f753ad.zip
system/ssmtp: [PD] take, fix license
-rw-r--r--system/ssmtp/APKBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/system/ssmtp/APKBUILD b/system/ssmtp/APKBUILD
index b7ae28bc7..53f7211b1 100644
--- a/system/ssmtp/APKBUILD
+++ b/system/ssmtp/APKBUILD
@@ -1,27 +1,24 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=ssmtp
pkgver=2.64
pkgrel=11
-pkgdesc="Extremely simple MTA to get mail off the system to a mail hub"
-subpackages="$pkgname-doc"
-arch="all"
+pkgdesc="Simple MTA to transmit mail to a mail hub"
url="https://packages.debian.org/stable/mail/ssmtp"
-license="GPL2"
+arch="all"
+options="!check"
+license="GPL-2.0+"
depends=
makedepends="openssl-dev autoconf"
-options="!check"
-provides="/usr/sbin/sendmail"
+subpackages="$pkgname-doc"
source="http://ftp.debian.org/debian/pool/main/s/$pkgname/${pkgname}_${pkgver}.orig.tar.bz2
generate_config.patch
libcrypto-underlinking.patch
inet6-getaddrinfo.patch
"
-_builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
sed -i -e 's:$(CC) -o:$(CC) @LDFLAGS@ -o:' Makefile.in
autoconf
@@ -32,13 +29,12 @@ build() {
--mandir=/usr/share/man \
--sysconfdir=/etc \
--enable-ssl \
- --enable-inet6 \
- || return 1
+ --enable-inet6
make
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$builddir"
make prefix="$pkgdir"/usr \
etcdir="$pkgdir"/etc \
mandir="$pkgdir"/usr/share/man \