summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-12-04 00:45:07 +0000
committerZach van Rijn <me@zv.io>2022-12-03 19:07:44 -0600
commitd262cc5c0f9168fc07f9c844600ec06d8330a21e (patch)
treee4ab5ff33c29b682dd30ee3d9e327c709a29d9b7
parent57ba41a5c0b9244b3e87536235a3ce4e28c44c64 (diff)
downloadpackages-d262cc5c0f9168fc07f9c844600ec06d8330a21e.tar.gz
packages-d262cc5c0f9168fc07f9c844600ec06d8330a21e.tar.bz2
packages-d262cc5c0f9168fc07f9c844600ec06d8330a21e.tar.xz
packages-d262cc5c0f9168fc07f9c844600ec06d8330a21e.zip
user/py3-pyirc: Update for new taillight
Fixes: #906
-rw-r--r--user/py3-pyirc/APKBUILD9
-rw-r--r--user/py3-pyirc/new-taillight.patch21
2 files changed, 27 insertions, 3 deletions
diff --git a/user/py3-pyirc/APKBUILD b/user/py3-pyirc/APKBUILD
index edfbec00b..25d340f7b 100644
--- a/user/py3-pyirc/APKBUILD
+++ b/user/py3-pyirc/APKBUILD
@@ -10,10 +10,12 @@ pkgdesc="An extensible and easy-to-use IRC library for Python"
url="https://foxkit-us.github.io/PyIRC/"
arch="noarch"
license="WTFPL OR LPRAB"
-depends="python3 py3-taillight~0.3"
+depends="python3 py3-taillight"
makedepends=""
giturl="https://code.foxkit.us/IRC/PyIRC"
-source="https://dev.sick.bike/dist/$pkgname-$pkgver.tar.gz"
+source="https://dev.sick.bike/dist/$pkgname-$pkgver.tar.gz
+ new-taillight.patch
+ "
build() {
python3 setup.py build
@@ -27,4 +29,5 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="0198aeae59e37f3bd94f96bedc294006049794dc208d6a7d18a0e07095d36fa921af08fb8a50be91022305a01304bb6202eb464b8861e595c71c5cf14f7c7850 py3-pyirc-3.0b1_git20190929.tar.gz"
+sha512sums="0198aeae59e37f3bd94f96bedc294006049794dc208d6a7d18a0e07095d36fa921af08fb8a50be91022305a01304bb6202eb464b8861e595c71c5cf14f7c7850 py3-pyirc-3.0b1_git20190929.tar.gz
+249c99ff2f4194bc431429fbca92eb473e7f54c0a49a5ebfb5778494332eb6b94378e727e31b112a4d2fcabcbf5d8d5ca95fe48777ea56afba4c2285fab7e5ca new-taillight.patch"
diff --git a/user/py3-pyirc/new-taillight.patch b/user/py3-pyirc/new-taillight.patch
new file mode 100644
index 000000000..51ca7f8e0
--- /dev/null
+++ b/user/py3-pyirc/new-taillight.patch
@@ -0,0 +1,21 @@
+Update priority enum for Taillight >= 0.4.
+
+--- py3-pyirc-3.0b1_git20190929/PyIRC/signal.py.old 2019-09-29 17:01:50.000000000 +0000
++++ py3-pyirc-3.0b1_git20190929/PyIRC/signal.py 2022-12-04 00:44:03.697227554 +0000
+@@ -12,14 +12,14 @@
+ from inspect import getmembers
+ from logging import getLogger
+
+-from taillight.signal import UnsharedSignal
++from taillight.signal import SignalPriority, UnsharedSignal
+ from taillight import ANY
+
+
+ _logger = getLogger(__name__) # pylint: disable=invalid-name
+
+
+-def event(hclass, event_name, priority=UnsharedSignal.PRIORITY_NORMAL,
++def event(hclass, event_name, priority=SignalPriority.PRIORITY_NORMAL,
+ listener=ANY):
+ """Tag a function as an event for later binding.
+