summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-23 21:31:44 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-23 21:31:44 -0500
commitd3b963a666595380559e35d5937595418e5df323 (patch)
tree46b72d419732b5b80aeb1eb74f32a47593e58b8c
parenta1461cea06eda159cba68fa5c12b9da8ad5296ed (diff)
downloadpackages-d3b963a666595380559e35d5937595418e5df323.tar.gz
packages-d3b963a666595380559e35d5937595418e5df323.tar.bz2
packages-d3b963a666595380559e35d5937595418e5df323.tar.xz
packages-d3b963a666595380559e35d5937595418e5df323.zip
system/grep: [PD] take, fix up, re-enable tests
-rw-r--r--system/grep/APKBUILD13
-rw-r--r--system/grep/gnulib-tests-dont-require-gpg-passphrase.patch10
2 files changed, 16 insertions, 7 deletions
diff --git a/system/grep/APKBUILD b/system/grep/APKBUILD
index fc9ed5baf..442d666a6 100644
--- a/system/grep/APKBUILD
+++ b/system/grep/APKBUILD
@@ -1,5 +1,6 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=grep
pkgver=3.1
pkgrel=2
@@ -9,12 +10,10 @@ arch="all"
license="GPL-3.0+"
makedepends="pcre-dev autoconf automake"
checkdepends="coreutils bash diffutils"
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc $pkgname-lang"
source="http://mirrors.kernel.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
+ gnulib-tests-dont-require-gpg-passphrase.patch
fix-tests.patch"
-builddir="$srcdir/$pkgname-$pkgver"
-# for whatever reason, all the builders locked up in the testsuite. investigate later.
-options="!check"
prepare() {
default_prepare
@@ -31,8 +30,7 @@ build() {
--bindir=/bin \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --disable-nls
+ --infodir=/usr/share/info
make
}
@@ -49,4 +47,5 @@ package() {
}
sha512sums="05494381c7dd8aad7e2ee4c17450de8d7b969a99dcfe17747db60df3475bf02d5323d091e896e8343e4f3251c29dc7f0b7a9f93c575c9d58ee2a57014c2c9d26 grep-3.1.tar.xz
+fd97fccd661befc558b3afb3e32c82dd2cef511a05e6129d49540599297c1b59ab1f109e63a12f585a2348c26c28fb98330c348829d1fe61cf8149d0dd1c989c gnulib-tests-dont-require-gpg-passphrase.patch
9ba6b01c0c74933299afb469dadd2ea0c7e24befa34c691671a576063e32a1f0c735541e5e2bb0073d8afd814790909f7f895827aa8a2fbacdfcae380a7bcb11 fix-tests.patch"
diff --git a/system/grep/gnulib-tests-dont-require-gpg-passphrase.patch b/system/grep/gnulib-tests-dont-require-gpg-passphrase.patch
new file mode 100644
index 000000000..b64993187
--- /dev/null
+++ b/system/grep/gnulib-tests-dont-require-gpg-passphrase.patch
@@ -0,0 +1,10 @@
+--- grep-3.1/gnulib-tests/test-vc-list-files-git.sh.old 2018-01-03 18:36:29.000000000 -0600
++++ grep-3.1/gnulib-tests/test-vc-list-files-git.sh 2018-06-18 21:57:08.305562148 -0500
+@@ -32,6 +32,7 @@
+ touch d/a b c &&
+ git config user.email "you@example.com" &&
+ git config user.name "Your Name" &&
++ git config commit.gpgsign false &&
+ git add . > /dev/null &&
+ git commit -q -a -m log &&
+ printf '%s\n' b c d/a > expected &&