summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-08 15:24:10 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-08 15:24:10 +0000
commitd5e1644d99b283f9045e659bad5198be0b6da8e0 (patch)
tree40a3cc3f173e23a2e6fb48716445c81dd5a06ecc
parent2b1a10d34bf6683f737aa1e510101b340c8df3db (diff)
downloadpackages-d5e1644d99b283f9045e659bad5198be0b6da8e0.tar.gz
packages-d5e1644d99b283f9045e659bad5198be0b6da8e0.tar.bz2
packages-d5e1644d99b283f9045e659bad5198be0b6da8e0.tar.xz
packages-d5e1644d99b283f9045e659bad5198be0b6da8e0.zip
system/musl: define __USE_TIME_BITS64
-rw-r--r--system/musl/APKBUILD2
-rw-r--r--system/musl/amalgamation.patch12
2 files changed, 13 insertions, 1 deletions
diff --git a/system/musl/APKBUILD b/system/musl/APKBUILD
index 27b39f584..6ed68e10e 100644
--- a/system/musl/APKBUILD
+++ b/system/musl/APKBUILD
@@ -117,7 +117,7 @@ utils() {
}
sha512sums="7026b67590a5dc0eda96777476a902e3d7121813d9ff9d9dabec3774365b9d43ce06314c434224fc8eef2b858107e42c10f220b6009ce4b919d8d9996cfcb839 musl-1.2.0_alpha1.tar.xz
-3f2f4eb4bfa1ddb19276e85fa97bf65dfc804cf9ea6e8ad7f1fef4a7930439e840d270f17c3b7e9dc816beb6ba4e33132b0b1a004750bff365161d63c8e8855e amalgamation.patch
+90cc7d683ea62a6b89f5bf4b782d4d70ee59a0498ad938a78c224b4e1058d45e4a196cf9278e57d7f57e40931072c339a9cbcafb8f0b2a902b485e9c757eec9a amalgamation.patch
88ae443dbb8e0a4368235bdc3a1c5c7b718495afa75e06deb8e01becc76cb1f0d6964589e2204fc749c9c1b3190b8b9ac1ae2c0099cab8e2ce3ec877103d4332 3001-make-real-lastlog-h.patch
6a7ff16d95b5d1be77e0a0fbb245491817db192176496a57b22ab037637d97a185ea0b0d19da687da66c2a2f5578e4343d230f399d49fe377d8f008410974238 handle-aux-at_base.patch
ded41235148930f8cf781538f7d63ecb0c65ea4e8ce792565f3649ee2523592a76b2a166785f0b145fc79f5852fd1fb1729a7a09110b3b8f85cba3912e790807 fgetspent_r.patch
diff --git a/system/musl/amalgamation.patch b/system/musl/amalgamation.patch
index 8f018a07a..fd77581da 100644
--- a/system/musl/amalgamation.patch
+++ b/system/musl/amalgamation.patch
@@ -46,6 +46,18 @@ index 194c2033..5734b1f0 100644
int mkostemps (char *, int, int);
void *valloc (size_t);
void *memalign(size_t, size_t);
+diff --git a/include/sys/time.h b/include/sys/time.h
+index cdc67ef6..fd773896 100644
+--- a/include/sys/time.h
++++ b/include/sys/time.h
+@@ -13,6 +13,7 @@ int gettimeofday (struct timeval *__restrict, void *__restrict);
+ #define ITIMER_REAL 0
+ #define ITIMER_VIRTUAL 1
+ #define ITIMER_PROF 2
++#define __USE_TIME_BITS64 1
+
+ struct itimerval {
+ struct timeval it_interval;
diff --git a/include/time.h b/include/time.h
index 5494df18..2412fe22 100644
--- a/include/time.h