summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-23 04:55:31 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-23 04:55:31 -0500
commite36202b3724d5d21aeccec81f11d76d7ceda1593 (patch)
treef21bb609bd1bb1482386c66cb9d3b871b930d32b
parent928ee8558a3eec0fa3044c9008f2f84bfd472d61 (diff)
downloadpackages-e36202b3724d5d21aeccec81f11d76d7ceda1593.tar.gz
packages-e36202b3724d5d21aeccec81f11d76d7ceda1593.tar.bz2
packages-e36202b3724d5d21aeccec81f11d76d7ceda1593.tar.xz
packages-e36202b3724d5d21aeccec81f11d76d7ceda1593.zip
user/xf86-input-libinput: pull in, take, bump to 0.28.0, fix
-rw-r--r--user/xf86-input-libinput/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/user/xf86-input-libinput/APKBUILD b/user/xf86-input-libinput/APKBUILD
new file mode 100644
index 000000000..246e3afd1
--- /dev/null
+++ b/user/xf86-input-libinput/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=xf86-input-libinput
+pkgver=0.28.0
+pkgrel=0
+pkgdesc="X.Org input driver - libinput universal driver"
+url="https://www.X.Org/"
+arch="all"
+license="MIT"
+depends=""
+depends_dev="libinput-dev xorg-server-dev"
+makedepends="$depends_dev eudev-dev xorgproto-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://www.X.Org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+
+sha512sums="4276b6aea87ddc83fa1f5e8d8949e34ad117186a6b5b599549231cb90424cd0fa69f3a4701ce529739c676665bb5c936eb447817c9420511d23bc048f6be92a4 xf86-input-libinput-0.28.0.tar.bz2"