summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-15 23:14:27 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-15 23:14:27 -0500
commite4c9aef3202e2b476c8573acbf45361afe69ac60 (patch)
tree6db4553ed07437077821d75314a574c4539b020a
parent084cf66685516d1b8edb6324a2503af7bc9e3249 (diff)
downloadpackages-e4c9aef3202e2b476c8573acbf45361afe69ac60.tar.gz
packages-e4c9aef3202e2b476c8573acbf45361afe69ac60.tar.bz2
packages-e4c9aef3202e2b476c8573acbf45361afe69ac60.tar.xz
packages-e4c9aef3202e2b476c8573acbf45361afe69ac60.zip
user/hwdata: pull in, bump, fix
-rw-r--r--user/hwdata/APKBUILD47
-rw-r--r--user/hwdata/install-T.patch11
2 files changed, 58 insertions, 0 deletions
diff --git a/user/hwdata/APKBUILD b/user/hwdata/APKBUILD
new file mode 100644
index 000000000..6fd70a252
--- /dev/null
+++ b/user/hwdata/APKBUILD
@@ -0,0 +1,47 @@
+# Maintainer:
+pkgname=hwdata
+pkgver=0.313
+pkgrel=0
+pkgdesc="Hardware identification and configuration data"
+url="https://github.com/vcrhonek/hwdata"
+arch="noarch"
+options="!check" # requires pciutils, which causes build loop
+license="GPL-2.0+"
+subpackages="$pkgname-usb $pkgname-pci $pkgname-pnp $pkgname-oui"
+depends="$subpackages"
+makedepends="bash"
+source="$pkgname-$pkgver.tar.gz::https://github.com/vcrhonek/hwdata/archive/v$pkgver.tar.gz
+ install-T.patch"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --datadir=/usr/share
+ # nothing to make
+}
+
+package() {
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install
+ # remove modprobe blacklist
+ rm -r "$pkgdir"/usr/lib
+}
+
+_mv() {
+ pkgdesc="$pkgdesc - $1"
+ depends=""
+ mkdir -p "$subpkgdir"/usr/share/hwdata
+ mv "$pkgdir"/usr/share/hwdata/$1 "$subpkgdir"/usr/share/hwdata
+}
+
+usb() { replaces="usbutils"; _mv usb.ids; }
+pci() { replaces="pciutils"; _mv pci.ids; }
+pnp() { _mv pnp.ids; }
+oui() { _mv oui.txt; }
+
+sha512sums="ad292112e96ebdf694f68a98f7d6d8cb20423e47aab44a5a5d283320c7d2becc885119d696c74e746dc9202cc79d32d628fad6d66ca5675fc24366ba6b39328a hwdata-0.313.tar.gz
+88a786d8feb5c8b7de587ac70f3e4307d10ac5ed9b0edfc8711de1ba51808ca33a76df518cb5a508215c309289a079a778a91c3e6fc359d644d230de8d23f049 install-T.patch"
diff --git a/user/hwdata/install-T.patch b/user/hwdata/install-T.patch
new file mode 100644
index 000000000..a98400841
--- /dev/null
+++ b/user/hwdata/install-T.patch
@@ -0,0 +1,11 @@
+--- ./Makefile.orig 2014-04-22 06:38:35.320410230 +0000
++++ ./Makefile 2014-04-22 06:39:15.260889885 +0000
+@@ -33,7 +33,7 @@
+ install -m 644 $$foo $(DESTDIR)$(datadir)/$(NAME) ;\
+ done
+ mkdir -p -m 755 $(DESTDIR)$(libdir)/modprobe.d
+- install -m 644 -T blacklist.conf $(DESTDIR)$(libdir)/modprobe.d/dist-blacklist.conf
++ install -m 644 blacklist.conf $(DESTDIR)$(libdir)/modprobe.d/dist-blacklist.conf
+
+ commit:
+ git commit -a ||: