summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-14 10:08:19 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-14 10:08:19 +0000
commite70325e83d97d6cef9bd38f6c5e4e0a7af5dd6fc (patch)
tree4df05ec7d211d0ea00d087e5ef7e17f1eb56248f
parentcd33dc8f0ee48b00991e1b0f8833b8e65a8770d8 (diff)
downloadpackages-e70325e83d97d6cef9bd38f6c5e4e0a7af5dd6fc.tar.gz
packages-e70325e83d97d6cef9bd38f6c5e4e0a7af5dd6fc.tar.bz2
packages-e70325e83d97d6cef9bd38f6c5e4e0a7af5dd6fc.tar.xz
packages-e70325e83d97d6cef9bd38f6c5e4e0a7af5dd6fc.zip
user/*: Modernise / fix syntax / deps / code / tests
-rw-r--r--user/alkimia/APKBUILD7
-rw-r--r--user/alkimia/webkit.patch32
-rw-r--r--user/dosbox/APKBUILD5
-rw-r--r--user/gnucobol/APKBUILD11
-rw-r--r--user/gnucobol/big-endian.patch28
-rw-r--r--user/gnucobol/dash-compat.patch29
-rw-r--r--user/htop/APKBUILD9
-rw-r--r--user/htop/correctness.patch78
-rw-r--r--user/libid3tag/APKBUILD6
-rw-r--r--user/libid3tag/gperf.patch12
-rw-r--r--user/minivmac/APKBUILD11
-rw-r--r--user/nmap/APKBUILD7
12 files changed, 196 insertions, 39 deletions
diff --git a/user/alkimia/APKBUILD b/user/alkimia/APKBUILD
index d9e302a78..fa4d4c35d 100644
--- a/user/alkimia/APKBUILD
+++ b/user/alkimia/APKBUILD
@@ -14,7 +14,9 @@ makedepends="$depends_dev cmake extra-cmake-modules qt5-qtwebkit-dev
kconfig-dev kcoreaddons-dev kdelibs4support-dev knewstuff-dev
kpackage-dev plasma-framework-dev"
subpackages="$pkgname-dev $pkgname-lang"
-source="https://download.kde.org/stable/alkimia/$pkgver/alkimia-$pkgver.tar.xz"
+source="https://download.kde.org/stable/alkimia/$pkgver/alkimia-$pkgver.tar.xz
+ webkit.patch
+ "
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -39,4 +41,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="5c0c121cac121f68042208ea9b126e4916ee4fa11f41d99709fbf11c44f433ec5eb0c0e112a4e6dc9ccfbc8a5295729cee566783f089bbe9ec2b32b5084839a6 alkimia-8.0.2.tar.xz"
+sha512sums="5c0c121cac121f68042208ea9b126e4916ee4fa11f41d99709fbf11c44f433ec5eb0c0e112a4e6dc9ccfbc8a5295729cee566783f089bbe9ec2b32b5084839a6 alkimia-8.0.2.tar.xz
+0a9db2efedb01bcd31a3d15890b00f2186d4ff1fc37426f09bd659ae757afca15f996a52f4b6cc64b6b8dfd7010683bbb6e72c8e89a3332b37f4c85828e2de76 webkit.patch"
diff --git a/user/alkimia/webkit.patch b/user/alkimia/webkit.patch
new file mode 100644
index 000000000..224ac2e8b
--- /dev/null
+++ b/user/alkimia/webkit.patch
@@ -0,0 +1,32 @@
+--- alkimia-8.0.2/src/CMakeLists.txt.old 2019-09-06 16:21:26.219957302 +0000
++++ alkimia-8.0.2/src/CMakeLists.txt 2020-01-14 09:56:58.676667188 +0000
+@@ -115,7 +115,6 @@
+ alkimia-internal
+ ${QT_USE_LIBSPREFIX}Core
+ ${ALKIMIA_LIBS}
+- ${QT_USE_LIBSPREFIX}WebKit
+ ${QT_USE_LIBSPREFIX}DBus
+ PUBLIC
+ ${MP_LIBRARIES}
+--- alkimia-8.0.2/autotests/CMakeLists.txt.old 2019-09-06 16:21:26.211957302 +0000
++++ alkimia-8.0.2/autotests/CMakeLists.txt 2020-01-14 09:57:05.305955497 +0000
+@@ -5,7 +5,7 @@
+ ${QT_USE_LIBSPREFIX}Test
+ ${QT_USE_LIBSPREFIX}Core
+ ${QT_USE_LIBSPREFIX}DBus
+- ${QT_USE_LIBSPREFIX}WebKit
++ ${QT_USE_LIBSPREFIX}WebKitWidgets
+ ${MP_LIBRARIES}
+ )
+
+--- alkimia-8.0.2/tests/CMakeLists.txt.old 2019-09-06 16:21:26.219957302 +0000
++++ alkimia-8.0.2/tests/CMakeLists.txt 2020-01-14 09:57:10.785367251 +0000
+@@ -3,7 +3,7 @@
+ alkimia
+ alkimia-internal
+ ${QT_USE_LIBSPREFIX}Core
+- ${QT_USE_LIBSPREFIX}WebKit
++ ${QT_USE_LIBSPREFIX}WebKitWidgets
+ )
+
+ if(BUILD_QT4)
diff --git a/user/dosbox/APKBUILD b/user/dosbox/APKBUILD
index e8674b531..e811aa22c 100644
--- a/user/dosbox/APKBUILD
+++ b/user/dosbox/APKBUILD
@@ -9,7 +9,8 @@ arch="all !s390x"
options="!check" # dosbox does not ship tests
license="GPL-2.0-only"
depends=""
-makedepends="ncurses-dev zlib-dev libxkbfile-dev libpng-dev libpcap-dev fluidsynth-dev sdl2-dev alsa-lib-dev"
+makedepends="ncurses-dev zlib-dev libxkbfile-dev libpng-dev libpcap-dev
+ fluidsynth-dev sdl2-dev alsa-lib-dev autoconf automake libtool"
source="https://github.com/joncampbell123/dosbox-x/archive/dosbox-x-wip-20180513-1316.tar.gz
porttalk-fix.patch
asmfix.patch
@@ -20,7 +21,6 @@ source="https://github.com/joncampbell123/dosbox-x/archive/dosbox-x-wip-20180513
builddir="$srcdir/dosbox-x-dosbox-x-wip-20180513-1316"
build() {
- cd "$builddir"
./autogen.sh
./configure \
--build=$CBUILD \
@@ -33,7 +33,6 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/gnucobol/APKBUILD b/user/gnucobol/APKBUILD
index c95083a7f..1173da988 100644
--- a/user/gnucobol/APKBUILD
+++ b/user/gnucobol/APKBUILD
@@ -11,13 +11,15 @@ license="GPL-3.0+ AND LGPL-3.0+ AND GFDL-1.3"
# Since it compiles to C as an intermediate, the headers / libraries must
# always be present and thus there is no -dev subpackage.
depends="db-dev gmp-dev ncurses-dev"
-makedepends="help2man texinfo"
+makedepends="autoconf automake help2man libtool texinfo"
subpackages="$pkgname-doc $pkgname-lang"
source="https://downloads.sourceforge.net/project/open-cobol/gnu-cobol/3.0/$pkgname-$_pkgver.tar.xz
https://dev.sick.bike/dist/newcob.val.Z
keep-debug-flags.patch
big-endian.patch
- tests-are-fatal.patch"
+ tests-are-fatal.patch
+ dash-compat.patch
+ "
builddir="$srcdir/$pkgname-$_pkgver"
prepare() {
@@ -51,5 +53,6 @@ package() {
sha512sums="da669f7bef0c6664723dc88c20e28236ea31d5c933d9129b0132e929eb66f723995d3428b056164cf105bc22b38b8bc5fbf9d0d5b76df4ce6c08045837930fa0 gnucobol-3.0-rc1.tar.xz
eb784866d1a335834074fbe103b5c5f5da810d847ae14a64316ecbb2c0f95ef751d2f2ec609b8fa21ef0b775817dc61115a574608ec89750d779ae0afbb95379 newcob.val.Z
f45611c1298680b0c763094af662b3d1925d32379d33faff77862d7eaa3bf6225f68d5160a39a0822f54b570c923a53bc72dec54cff4f04f1162515834a40be2 keep-debug-flags.patch
-f7c1249db9d0f8d3a4eda732db93970f73fe649d1725b0b73c92af4885bc816d8727dbbcb8e9a1fb998997f3beed7de2812202749f05bbe1471b907737645648 big-endian.patch
-ca5ba1e19e5ff8740008b45ffcea4c1e8e34fc62246f3e635424ae1ec374c5cd9d7cc94d371690c021ccf82e293db7235143ebcaadb20ae5e4fc258749ff56c4 tests-are-fatal.patch"
+f8f8bb395e3f2e0e993df5133d1ed459dc7f03f148d76ddbbe4820f7674300c8c9a8d024785124444ca71a18a0d917e816ab852e0b5e9ebbfa5ed35f12a80b0f big-endian.patch
+ca5ba1e19e5ff8740008b45ffcea4c1e8e34fc62246f3e635424ae1ec374c5cd9d7cc94d371690c021ccf82e293db7235143ebcaadb20ae5e4fc258749ff56c4 tests-are-fatal.patch
+376af9b264b679388722b4d489a834cfb24b47fbdb6cd9bd9c239894741ffc265c2f83d770b0a820f48b3668b3596544183b48bee319186e4ed5c9c60bad4e77 dash-compat.patch"
diff --git a/user/gnucobol/big-endian.patch b/user/gnucobol/big-endian.patch
index 848300e15..65e5243d2 100644
--- a/user/gnucobol/big-endian.patch
+++ b/user/gnucobol/big-endian.patch
@@ -14,7 +14,7 @@ diff --git a/tests/testsuite.src/run_misc.at b/tests/testsuite.src/run_misc.at
index 2ef4a86..173ac48 100644
--- a/tests/testsuite.src/run_misc.at
+++ b/tests/testsuite.src/run_misc.at
-@@ -6185,6 +6185,10 @@ AT_CLEANUP
+@@ -5918,6 +5918,10 @@ AT_CLEANUP
AT_SETUP([MF FIGURATIVE to NUMERIC])
AT_KEYWORDS([MOVE])
@@ -25,7 +25,7 @@ index 2ef4a86..173ac48 100644
AT_DATA([prog.cob], [
IDENTIFICATION DIVISION.
PROGRAM-ID. prog.
-@@ -6230,12 +6234,16 @@ AT_DATA([prog.cob], [
+@@ -5963,12 +5967,16 @@ AT_DATA([prog.cob], [
DISPLAY "MOVE HIGH-VALUES TO BIGFLT"
MOVE HIGH-VALUES TO BIGFLT.
PERFORM SHOW-BIG.
@@ -42,7 +42,7 @@ index 2ef4a86..173ac48 100644
DISPLAY "MOVE ALL '21' TO BIGFLT"
MOVE ALL '21' TO BIGFLT.
PERFORM SHOW-BIG.
-@@ -6244,7 +6252,6 @@ AT_DATA([prog.cob], [
+@@ -5977,7 +5985,6 @@ AT_DATA([prog.cob], [
CALL "dump" USING MYFLD.
SHOW-BIG.
DISPLAY "BIGFLT is " BIGFLT.
@@ -50,7 +50,7 @@ index 2ef4a86..173ac48 100644
])
AT_DATA([cmod.c], [[
-@@ -6303,10 +6310,8 @@ BIGFLT is 2.1973164E-18
+@@ -6033,10 +6040,8 @@ BIGFLT is 2.1973164E-18
22222222 .
MOVE ALL * TO BIGFLT
BIGFLT is 5.4312347E+12
@@ -77,7 +77,7 @@ diff --git a/tests/testsuite.src/run_misc.at b/tests/testsuite.src/run_misc.at
index 173ac48..51f4b84 100644
--- a/tests/testsuite.src/run_misc.at
+++ b/tests/testsuite.src/run_misc.at
-@@ -6275,7 +6275,7 @@ prog.cob:28: warning: numeric value is expected
+@@ -6005,7 +6005,7 @@ prog.cob:28: warning: numeric value is expected
prog.cob:6: warning: 'MYFLD' defined here as PIC 9(4)
prog.cob:34: warning: numeric value is expected
prog.cob:6: warning: 'MYFLD' defined here as PIC 9(4)
@@ -105,7 +105,7 @@ diff --git a/libcob/common.c b/libcob/common.c
index 5262282..d99c533 100644
--- a/libcob/common.c
+++ b/libcob/common.c
-@@ -5275,9 +5275,7 @@ cob_sys_getopt_long_long (void *so, void *lo, void *idx, const int long_only, vo
+@@ -5138,9 +5138,7 @@ cob_sys_getopt_long_long (void *so, void *lo, void *idx, const int long_only, vo
COB_CHK_PARMS (CBL_GC_GETOPT, 6);
@@ -116,7 +116,7 @@ index 5262282..d99c533 100644
if (COB_MODULE_PTR->cob_procedure_params[1]) {
lo_size = COB_MODULE_PTR->cob_procedure_params[1]->size;
}
-@@ -5288,9 +5286,7 @@ cob_sys_getopt_long_long (void *so, void *lo, void *idx, const int long_only, vo
+@@ -5151,9 +5149,7 @@ cob_sys_getopt_long_long (void *so, void *lo, void *idx, const int long_only, vo
opt_val_size = COB_MODULE_PTR->cob_procedure_params[5]->size;
}
@@ -127,7 +127,7 @@ index 5262282..d99c533 100644
if (lo_size % sizeof (longoption_def) == 0) {
lo_amount = (int)lo_size / sizeof (longoption_def);
longoptions_root = (struct option*) cob_malloc (sizeof (struct option) * (lo_amount + 1U));
-@@ -5305,9 +5301,7 @@ cob_sys_getopt_long_long (void *so, void *lo, void *idx, const int long_only, vo
+@@ -5168,9 +5164,7 @@ cob_sys_getopt_long_long (void *so, void *lo, void *idx, const int long_only, vo
}
longind = cob_get_int (COB_MODULE_PTR->cob_procedure_params[2]);
@@ -138,7 +138,7 @@ index 5262282..d99c533 100644
shortoptions = cob_malloc (so_size + 1U);
if (COB_MODULE_PTR->cob_procedure_params[0]) {
cob_field_to_string (COB_MODULE_PTR->cob_procedure_params[0], shortoptions, so_size);
-@@ -5333,9 +5327,7 @@ cob_sys_getopt_long_long (void *so, void *lo, void *idx, const int long_only, vo
+@@ -5196,9 +5190,7 @@ cob_sys_getopt_long_long (void *so, void *lo, void *idx, const int long_only, vo
longoptions = longoptions + 1;
}
@@ -149,7 +149,7 @@ index 5262282..d99c533 100644
longoptions->name = NULL;
longoptions->has_arg = 0;
longoptions->flag = NULL;
-@@ -5348,17 +5340,42 @@ cob_sys_getopt_long_long (void *so, void *lo, void *idx, const int long_only, vo
+@@ -5211,17 +5203,42 @@ cob_sys_getopt_long_long (void *so, void *lo, void *idx, const int long_only, vo
return_value = cob_getopt_long_long (cob_argc, cob_argv, shortoptions, longoptions, &longind, long_only);
temp = (char *) &return_value;
@@ -218,7 +218,7 @@ diff --git a/libcob/fileio.c b/libcob/fileio.c
index 885cd48..521e245 100644
--- a/libcob/fileio.c
+++ b/libcob/fileio.c
-@@ -5633,6 +5633,22 @@ cob_sys_open_file (unsigned char *file_name, unsigned char *file_access,
+@@ -5559,6 +5559,22 @@ cob_sys_open_file (unsigned char *file_name, unsigned char *file_access,
COB_CHK_PARMS (CBL_OPEN_FILE, 5);
@@ -241,7 +241,7 @@ index 885cd48..521e245 100644
return open_cbl_file (file_name, file_access, file_handle, 0);
}
-@@ -5647,6 +5663,24 @@ cob_sys_create_file (unsigned char *file_name, unsigned char *file_access,
+@@ -5573,6 +5589,24 @@ cob_sys_create_file (unsigned char *file_name, unsigned char *file_access,
* @param: file_dev : not implemented, set 0
*/
@@ -266,7 +266,7 @@ index 885cd48..521e245 100644
if (*file_lock != 0) {
cob_runtime_warning (_("call to CBL_CREATE_FILE with wrong file_lock: %d"), *file_lock);
}
-@@ -5654,8 +5688,6 @@ cob_sys_create_file (unsigned char *file_name, unsigned char *file_access,
+@@ -5580,8 +5614,6 @@ cob_sys_create_file (unsigned char *file_name, unsigned char *file_access,
cob_runtime_warning (_("call to CBL_CREATE_FILE with wrong file_dev: %d"), *file_dev);
}
@@ -300,7 +300,7 @@ index 7c3c660..5ddbd58 100644
## Written by Keisuke Nishida, Roger While, Simon Sobisch, Edward Hart
##
## This file is part of GnuCOBOL.
-@@ -4254,7 +4254,7 @@ AT_CLEANUP
+@@ -4145,7 +4145,7 @@ AT_CLEANUP
AT_SETUP([UDF with recursion])
AT_KEYWORDS([functions LOCAL-STORAGE])
diff --git a/user/gnucobol/dash-compat.patch b/user/gnucobol/dash-compat.patch
new file mode 100644
index 000000000..e2d7f6006
--- /dev/null
+++ b/user/gnucobol/dash-compat.patch
@@ -0,0 +1,29 @@
+--- gnucobol-3.0-rc1/tests/testsuite.src/listings.at.old 2018-04-22 19:55:50.000000000 +0000
++++ gnucobol-3.0-rc1/tests/testsuite.src/listings.at 2020-01-14 09:08:26.488668118 +0000
+@@ -2185,7 +2185,7 @@
+
+ AT_CHECK([$UNIFY_LISTING prog.lst prog.lis once], [0], [], [])
+
+-AT_CHECK([test "$COB_HAS_64_BIT_POINTER" == "yes"], [0], [], [],
++AT_CHECK([test "$COB_HAS_64_BIT_POINTER" = "yes"], [0], [], [],
+
+ # Previous test "failed" --> 32 bit
+
+@@ -5761,4 +5761,4 @@
+ AT_CHECK([$UNIFY_LISTING prog.lst prog.lis once], [0], [], [])
+ AT_CHECK([diff prog1.lst prog.lis], [0], [], [])
+
+-AT_CLEANUP
+\ No newline at end of file
++AT_CLEANUP
+--- gnucobol-3.0-rc1/tests/testsuite.src/data_pointer.at.old 2018-04-22 19:55:46.000000000 +0000
++++ gnucobol-3.0-rc1/tests/testsuite.src/data_pointer.at 2020-01-14 09:08:48.226341564 +0000
+@@ -40,7 +40,7 @@
+
+ AT_CHECK([$COMPILE prog.cob], [0], [], [])
+
+-AT_CHECK([test "$COB_HAS_64_BIT_POINTER" == "yes"], [0], [], [],
++AT_CHECK([test "$COB_HAS_64_BIT_POINTER" = "yes"], [0], [], [],
+
+ # Previous test "failed" --> 32 bit
+
diff --git a/user/htop/APKBUILD b/user/htop/APKBUILD
index 2dc87cfa7..25b992f1a 100644
--- a/user/htop/APKBUILD
+++ b/user/htop/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=htop
pkgver=2.2.0
-pkgrel=0
+pkgrel=1
pkgdesc="Interactive process viewer"
url="http://hisham.hm/htop"
arch="all"
@@ -12,10 +12,11 @@ depends=""
makedepends="ncurses-dev python3"
subpackages="$pkgname-doc"
source="http://hisham.hm/htop/releases/$pkgver/$pkgname-$pkgver.tar.gz
- fix-python-path.patch"
+ correctness.patch
+ fix-python-path.patch
+ "
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -29,9 +30,9 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
sha512sums="ec1335bf0e3e0387e5e50acbc508d0effad19c4bc1ac312419dc97b82901f4819600d6f87a91668f39d429536d17304d4b14634426a06bec2ecd09df24adc62e htop-2.2.0.tar.gz
+010ca1d42caeea133ba3d0383373a8eca849c73c95bb98fe3222c458c44320d1e2a3aee9431213721f1ccfcbd5af54eb1e54fafd6e0e5ca3b87499ee6d04b49a correctness.patch
16358bcd6d83181cc04dd8a7971f7cc0804dc49995208bad2042bcca7962f562bbd008c2185f24aa6186c58896e94e4ec02e2053dc46ed14789889d64836b679 fix-python-path.patch"
diff --git a/user/htop/correctness.patch b/user/htop/correctness.patch
new file mode 100644
index 000000000..51a9848d2
--- /dev/null
+++ b/user/htop/correctness.patch
@@ -0,0 +1,78 @@
+From: Jonathan Currier <dullfire@yahoo.com>
+
+diff --git a/MainPanel.h b/MainPanel.h
+index 8849659..471870b 100644
+--- a/MainPanel.h
++++ b/MainPanel.h
+@@ -12,6 +12,7 @@ in the source distribution for its full text.
+ #include "Panel.h"
+ #include "Action.h"
+ #include "Settings.h"
++#include "union-arg.h"
+
+ typedef struct MainPanel_ {
+ Panel super;
+@@ -21,11 +22,6 @@ typedef struct MainPanel_ {
+ pid_t pidSearch;
+ } MainPanel;
+
+-typedef union {
+- int i;
+- void* v;
+-} Arg;
+-
+ typedef bool(*MainPanel_ForeachProcessFn)(Process*, Arg);
+
+ #define MainPanel_getFunctionBar(this_) (((Panel*)(this_))->defaultBar)
+diff --git a/Process.c b/Process.c
+index 471f529..ae617a6 100644
+--- a/Process.c
++++ b/Process.c
+@@ -548,7 +548,9 @@ bool Process_changePriorityBy(Process* this, int delta) {
+ return Process_setPriority(this, this->nice + delta);
+ }
+
+-void Process_sendSignal(Process* this, int sgn) {
++
++void Process_sendSignal(Process* this, Arg arg) {
++ int sgn = arg.i;
+ CRT_dropPrivileges();
+ kill(this->pid, (int) sgn);
+ CRT_restorePrivileges();
+diff --git a/Process.h b/Process.h
+index f702ca0..3011845 100644
+--- a/Process.h
++++ b/Process.h
+@@ -29,6 +29,7 @@ in the source distribution for its full text.
+ #include "Object.h"
+
+ #include <sys/types.h>
++#include "union-arg.h"
+
+ #define PROCESS_FLAG_IO 0x0001
+
+@@ -199,7 +200,7 @@ bool Process_setPriority(Process* this, int priority);
+
+ bool Process_changePriorityBy(Process* this, int delta);
+
+-void Process_sendSignal(Process* this, int sgn);
++void Process_sendSignal(Process* this, Arg arg);
+
+ long Process_pidCompare(const void* v1, const void* v2);
+
+diff --git a/union-arg.h b/union-arg.h
+new file mode 100644
+index 0000000..5c8a094
+--- /dev/null
++++ b/union-arg.h
+@@ -0,0 +1,9 @@
++#ifndef UNION_ARG_HEADER
++#define UNION_ARG_HEADER
++
++typedef union {
++ int i;
++ void* v;
++} Arg;
++
++#endif
+
diff --git a/user/libid3tag/APKBUILD b/user/libid3tag/APKBUILD
index 0984fc93f..e20e012d5 100644
--- a/user/libid3tag/APKBUILD
+++ b/user/libid3tag/APKBUILD
@@ -8,11 +8,12 @@ url="http://www.underbit.com/products/mad/"
arch="all"
license="GPL-2.0+"
depends=""
-makedepends="zlib-dev"
+makedepends="gperf zlib-dev"
subpackages="$pkgname-dev"
source="ftp://ftp.mars.org/pub/mpeg/libid3tag-$pkgver.tar.gz
CVE-2004-2779.patch
CVE-2017-11550.patch
+ gperf.patch
"
# secfixes:
@@ -63,4 +64,5 @@ EOF
sha512sums="ade7ce2a43c3646b4c9fdc642095174b9d4938b078b205cd40906d525acd17e87ad76064054a961f391edcba6495441450af2f68be69f116549ca666b069e6d3 libid3tag-0.15.1b.tar.gz
4c27e104d45ae34affc1bef8ec613e65c7e4791185d2ef1cb27974ec7025c06c35d30d6278ce7e3107dff959bd55a708246c3c1a9d5ad7b093424cfb93b79f63 CVE-2004-2779.patch
-6627d6e73958309b199a02cd6fa1008a81554151238d8a099dc27e535b8d14f7a9c1ba19894fdf2c927e59c0ca855d50b2f1289f116b45bc41e02d31659d1535 CVE-2017-11550.patch"
+6627d6e73958309b199a02cd6fa1008a81554151238d8a099dc27e535b8d14f7a9c1ba19894fdf2c927e59c0ca855d50b2f1289f116b45bc41e02d31659d1535 CVE-2017-11550.patch
+3f320d1d8719afd84aa0cf2a9e5615f3f535f84d1987f12df0a9d3f2b7c02e2c87fbc3aa41d538cdc4f8a30e629de6f3fc3a4e79f23448fd39d4c0c438c803fb gperf.patch"
diff --git a/user/libid3tag/gperf.patch b/user/libid3tag/gperf.patch
new file mode 100644
index 000000000..a365811c5
--- /dev/null
+++ b/user/libid3tag/gperf.patch
@@ -0,0 +1,12 @@
+diff -pur libid3tag-0.15.1b-orig/compat.h libid3tag-0.15.1b/compat.h
+--- libid3tag-0.15.1b-orig/compat.h 2004-01-23 10:41:32.000000000 +0100
++++ libid3tag-0.15.1b/compat.h 2017-03-15 01:49:23.808834401 +0100
+@@ -34,7 +34,7 @@ struct id3_compat {
+ };
+
+ struct id3_compat const *id3_compat_lookup(register char const *,
+- register unsigned int);
++ register size_t);
+
+ int id3_compat_fixup(struct id3_tag *);
+
diff --git a/user/minivmac/APKBUILD b/user/minivmac/APKBUILD
index 71a16a1b2..08a38f1fb 100644
--- a/user/minivmac/APKBUILD
+++ b/user/minivmac/APKBUILD
@@ -10,15 +10,12 @@ options="!check" # minivmac does not ship a test suite
license="GPL-2.0-only"
depends=""
makedepends="libx11-dev libxcb-dev libxau-dev libbsd-dev libxdmcp-dev"
-source="http://oddball.tech/code/emu_pkg/$pkgname-$pkgver.tar.xz"
+source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.xz"
build() {
- cd "$builddir"
CARCH=$CARCH ./configure
- cd "$builddir"/mnvmplus
- make -j1
- cd "$builddir"/mnvmII
- make -j1
+ make -C mnvmplus -j1
+ make -C mnvmII -j1
}
package() {
@@ -26,4 +23,4 @@ package() {
install -m755 "$builddir"/mnvmII/minivmac "$pkgdir"/usr/bin/minivmacII
}
-sha512sums="ff28266641dd37df74c84c16c8bf32282729d55ae6512d4a98abf92ba40692f9fc107b501f072755ba0f8a0322d4f755915d9be74a407ce89af94bfd24d11043 minivmac-3.5.8.tar.xz"
+sha512sums="ff28266641dd37df74c84c16c8bf32282729d55ae6512d4a98abf92ba40692f9fc107b501f072755ba0f8a0322d4f755915d9be74a407ce89af94bfd24d11043 minivmac-3.5.8.tar.xz"
diff --git a/user/nmap/APKBUILD b/user/nmap/APKBUILD
index 3b256aaa3..304c94cae 100644
--- a/user/nmap/APKBUILD
+++ b/user/nmap/APKBUILD
@@ -7,7 +7,8 @@ url="https://nmap.org/"
arch="all"
license="GPL-2.0-only"
depends=""
-makedepends="linux-headers openssl-dev libpcap-dev pcre-dev zlib-dev libssh2-dev lua5.3-dev"
+makedepends="linux-headers openssl-dev libpcap-dev pcre-dev zlib-dev
+ libssh2-dev lua5.3-dev"
subpackages="
$pkgname-doc
$pkgname-scripts::noarch
@@ -33,7 +34,7 @@ build() {
export CFLAGS=-g3
export CPPFLAGS=-g3
export CXXFLAGS=-g3
- ./configure \
+ LDFLAGS="$LDFLAGS -L/usr/lib/lua5.3" ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
@@ -47,7 +48,7 @@ build() {
--with-libpcre=yes \
--with-libz=yes \
--with-libssh2=yes \
- --with-liblua=/usr/lua5.3
+ --with-liblua=yes
make
}