summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-10-02 01:09:37 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-10-02 01:09:37 +0000
commitebbeb4b293aaa49301076af526bf7ad30bac426a (patch)
tree31212c5f4ad6445470cd4a790aa37852a9cb4a72
parentd781efa527bfc318d086667f935ebe9e96747232 (diff)
downloadpackages-ebbeb4b293aaa49301076af526bf7ad30bac426a.tar.gz
packages-ebbeb4b293aaa49301076af526bf7ad30bac426a.tar.bz2
packages-ebbeb4b293aaa49301076af526bf7ad30bac426a.tar.xz
packages-ebbeb4b293aaa49301076af526bf7ad30bac426a.zip
user/tmux: bump to 2.9a
-rw-r--r--user/tmux/APKBUILD10
-rw-r--r--user/tmux/xterm-DECLRMM.patch23
2 files changed, 4 insertions, 29 deletions
diff --git a/user/tmux/APKBUILD b/user/tmux/APKBUILD
index ebd0a38c0..12caf643d 100644
--- a/user/tmux/APKBUILD
+++ b/user/tmux/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer:
pkgname=tmux
-pkgver=2.7
-pkgrel=2
+pkgver=2.9a
+pkgrel=0
pkgdesc="Tool to control multiple terminals from a single terminal"
url="https://tmux.github.io/"
arch="all"
@@ -10,8 +10,7 @@ license="MIT"
depends="ncurses-terminfo"
makedepends="bsd-compat-headers libevent-dev libutempter-dev ncurses-dev"
subpackages="$pkgname-doc"
-source="https://github.com/tmux/tmux/releases/download/$pkgver/$pkgname-$pkgver.tar.gz
- xterm-DECLRMM.patch"
+source="https://github.com/tmux/tmux/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
build() {
./configure \
@@ -38,5 +37,4 @@ package() {
done
}
-sha512sums="7839ef748ea55df8c02c727047f65bd235b5e3b8ab23157246071e1b9954fa269594da9fbd0fabf6a850e3b5dfda962a0a067c1507411c92a84d1db2666ecf37 tmux-2.7.tar.gz
-7fb006f8f24d60614fcaeadace933c2ad6674d2476980736a830f63a40d7110638942478322336849d47707c99ab7de0cb01ff39806a4c9144650daf2f666773 xterm-DECLRMM.patch"
+sha512sums="aca6882688727c10c5647443fdd18bbd6c0f80b7a3bf9667903d1b89d523e604cd715f176f33f2e5673258f00e626a6dc273f80fe97ae4f91621814d89985713 tmux-2.9a.tar.gz"
diff --git a/user/tmux/xterm-DECLRMM.patch b/user/tmux/xterm-DECLRMM.patch
deleted file mode 100644
index b9bef3455..000000000
--- a/user/tmux/xterm-DECLRMM.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 26f274011096b9eacfd2753d8f7afcb63e796ab9 Mon Sep 17 00:00:00 2001
-From: nicm <nicm>
-Date: Thu, 1 Aug 2019 11:45:34 +0000
-Subject: [PATCH] xterm 348 now disables margins when resized, so send DECLRMM
- again.
-
----
- tty.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/tty.c b/tty.c
-index ab1da9fd3..024aef271 100644
---- a/tty.c
-+++ b/tty.c
-@@ -1879,6 +1879,8 @@ tty_invalidate(struct tty *tty)
- tty->rlower = tty->rright = UINT_MAX;
-
- if (tty->flags & TTY_STARTED) {
-+ if (tty_use_margin(tty))
-+ tty_puts(tty, "\033[?69h"); /* DECLRMM */
- tty_putcode(tty, TTYC_SGR0);
-
- tty->mode = ALL_MODES;