summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-04-26 10:29:08 -0500
committerKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-04-26 10:29:08 -0500
commitec20c9be31944dfa411bfdd4260f18707490433b (patch)
tree48e4e8335e37f75d82a16206ab33bbc05fbffe37
parent119e13460625d4e0a9942c68590d2ecf7a71bc60 (diff)
downloadpackages-ec20c9be31944dfa411bfdd4260f18707490433b.tar.gz
packages-ec20c9be31944dfa411bfdd4260f18707490433b.tar.bz2
packages-ec20c9be31944dfa411bfdd4260f18707490433b.tar.xz
packages-ec20c9be31944dfa411bfdd4260f18707490433b.zip
user/perl-multidimensional: new package
-rw-r--r--user/perl-multidimensional/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/perl-multidimensional/APKBUILD b/user/perl-multidimensional/APKBUILD
new file mode 100644
index 000000000..ef431756c
--- /dev/null
+++ b/user/perl-multidimensional/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-multidimensional
+pkgver=0.014
+pkgrel=0
+pkgdesc="Perl module for disabling multidimensional array emulation"
+url="https://metacpan.org/pod/multidimensional"
+arch="all"
+license="Artistic-1.0-Perl"
+depends=""
+makedepends="perl-b-hooks-op-check perl-dev perl-extutils-depends"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/I/IL/ILMARI/multidimensional-$pkgver.tar.gz"
+builddir="$srcdir/multidimensional-$pkgver"
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="94c9dabb3023165a8dd140ef791e4aab980e3b604eae06ed0e29290aab67a9302f2cde4c8b394de0b4c55c5f78ce4510db902d615d665bf60b12ec409f341043 multidimensional-0.014.tar.gz"