summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-10-03 17:41:59 -0500
committerMax Rees <maxcrees@me.com>2019-10-14 17:06:03 -0500
commitfc778b3fb99df10d4b04a625d7f15971ab704b17 (patch)
tree768342e88fd7f0b62b4f502f0ab337bda461e491
parentb5b897e47ab11998c46db7f9ba96410a187c0634 (diff)
downloadpackages-fc778b3fb99df10d4b04a625d7f15971ab704b17.tar.gz
packages-fc778b3fb99df10d4b04a625d7f15971ab704b17.tar.bz2
packages-fc778b3fb99df10d4b04a625d7f15971ab704b17.tar.xz
packages-fc778b3fb99df10d4b04a625d7f15971ab704b17.zip
system/findutils: bump to 4.7.0
-rw-r--r--system/findutils/APKBUILD16
-rw-r--r--system/findutils/gnulib-test-datetime.patch24
-rw-r--r--system/findutils/gnulib-tests-dont-require-gpg-passphrase.patch4
-rw-r--r--system/findutils/localename-test-fix.patch34
4 files changed, 34 insertions, 44 deletions
diff --git a/system/findutils/APKBUILD b/system/findutils/APKBUILD
index 05a9d955a..c789cd3a0 100644
--- a/system/findutils/APKBUILD
+++ b/system/findutils/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer:
pkgname=findutils
-pkgver=4.6.0
-pkgrel=2
+pkgver=4.7.0
+pkgrel=0
pkgdesc="GNU utilities for finding files"
url="https://www.gnu.org/software/findutils/"
arch="all"
@@ -12,10 +12,10 @@ depends=""
makedepends=""
checkdepends="coreutils diffutils dejagnu"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz
- localename-test-fix.patch
+source="https://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz
gnulib-tests-dont-require-gpg-passphrase.patch
sysmacros.patch
+ gnulib-test-datetime.patch
"
build() {
@@ -39,7 +39,7 @@ package() {
rm -rf "$pkgdir"/usr/lib
}
-sha512sums="41fcd4197c1efbd77f7420e5754e2cf9332dfef19f90c65a8fa1844bb4bc5d529c8393ee0ff979a054e9ac65ff71d7fe3921ea079f9960843412fc9a71f8afd4 findutils-4.6.0.tar.gz
-39fc0bc7602dd5300cf0b5488a7d14b6d00e05fedd6067ff45a229e65ff020d0003c0bb8e43807d9874afeb39c1dae6d612182caeb7de76156e1bc6ceb50adfc localename-test-fix.patch
-96351821572bee9e23760568b5a9f326c8727b6904a8b9f6fc8e5b8e14b42265c632cea09a913db830844f3015f91a03b9c4dd72862f40a3c3814556497434e2 gnulib-tests-dont-require-gpg-passphrase.patch
-2e214511de4be47dc0df46a83d4102e4b59b5f02c4b8356a1ed0b26d481e17c6604bbf07071960f219ef85e1687878cce69a8be28c46638ee4ebe9f4ce0ed487 sysmacros.patch"
+sha512sums="650a24507f8f4ebff83ad28dd27daa4785b4038dcaadc4fe00823b976e848527074cce3f9ec34065b7f037436d2aa6e9ec099bc05d7472c29864ac2c69de7f2e findutils-4.7.0.tar.xz
+dc7e9c4fdd36d05ca230e3456a8005a5fcd353db07181e0d17ab66db4eb967e6bdfe3b6f1da0edbb38e973fea89ae174ea31e6839f59d3084b15f08de363f139 gnulib-tests-dont-require-gpg-passphrase.patch
+2e214511de4be47dc0df46a83d4102e4b59b5f02c4b8356a1ed0b26d481e17c6604bbf07071960f219ef85e1687878cce69a8be28c46638ee4ebe9f4ce0ed487 sysmacros.patch
+8e367ba108b66ea27b2a289e51acbdf540d7e7ab5dfb8347a007eaf763355707db43c44e530fbec40f47578405880ff99d34eec97570365f2ab3439c4f1bf358 gnulib-test-datetime.patch"
diff --git a/system/findutils/gnulib-test-datetime.patch b/system/findutils/gnulib-test-datetime.patch
new file mode 100644
index 000000000..2b227fc27
--- /dev/null
+++ b/system/findutils/gnulib-test-datetime.patch
@@ -0,0 +1,24 @@
+--- coreutils-8.31/gnulib-tests/test-parse-datetime.c.old 2019-06-01 07:46:25.716292871 +0000
++++ coreutils-8.31/gnulib-tests/test-parse-datetime.c 2019-06-01 22:07:59.456653669 +0000
+@@ -432,21 +432,5 @@
+ ASSERT ( parse_datetime (&result, "TZ=\"\\\\\"", &now));
+ ASSERT ( parse_datetime (&result, "TZ=\"\\\"\"", &now));
+
+- /* Outlandishly-long time zone abbreviations should not cause problems. */
+- {
+- static char const bufprefix[] = "TZ=\"";
+- enum { tzname_len = 2000 };
+- static char const bufsuffix[] = "0\" 1970-01-01 01:02:03.123456789";
+- enum { bufsize = sizeof bufprefix - 1 + tzname_len + sizeof bufsuffix };
+- char buf[bufsize];
+- memcpy (buf, bufprefix, sizeof bufprefix - 1);
+- memset (buf + sizeof bufprefix - 1, 'X', tzname_len);
+- strcpy (buf + bufsize - sizeof bufsuffix, bufsuffix);
+- ASSERT (parse_datetime (&result, buf, &now));
+- LOG (buf, now, result);
+- ASSERT (result.tv_sec == 1 * 60 * 60 + 2 * 60 + 3
+- && result.tv_nsec == 123456789);
+- }
+-
+ return 0;
+ }
diff --git a/system/findutils/gnulib-tests-dont-require-gpg-passphrase.patch b/system/findutils/gnulib-tests-dont-require-gpg-passphrase.patch
index 755126f64..46b921ff9 100644
--- a/system/findutils/gnulib-tests-dont-require-gpg-passphrase.patch
+++ b/system/findutils/gnulib-tests-dont-require-gpg-passphrase.patch
@@ -1,5 +1,5 @@
---- findutils-4.6.0/tests/test-vc-list-files-git.sh.old 2018-01-03 18:36:29.000000000 -0600
-+++ findutils-4.6.0/tests/test-vc-list-files-git.sh 2018-06-18 21:57:08.305562148 -0500
+--- findutils-4.6.0/gnulib-tests/test-vc-list-files-git.sh.old 2018-01-03 18:36:29.000000000 -0600
++++ findutils-4.6.0/gnulib-tests/test-vc-list-files-git.sh 2018-06-18 21:57:08.305562148 -0500
@@ -32,6 +32,7 @@
touch d/a b c &&
git config user.email "you@example.com" &&
diff --git a/system/findutils/localename-test-fix.patch b/system/findutils/localename-test-fix.patch
deleted file mode 100644
index 666261f03..000000000
--- a/system/findutils/localename-test-fix.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- findutils-4.6.0/tests/localename.c.old 2016-12-31 13:54:43.000000000 +0000
-+++ findutils-4.6.0/tests/localename.c 2017-07-30 16:40:47.098541270 +0000
-@@ -40,7 +40,7 @@
- # if defined __APPLE__ && defined __MACH__
- # include <xlocale.h>
- # endif
--# if __GLIBC__ >= 2 && !defined __UCLIBC__
-+# if defined __linux__
- # include <langinfo.h>
- # endif
- # if !defined IN_LIBINTL
-@@ -2692,16 +2692,19 @@
- locale_t thread_locale = uselocale (NULL);
- if (thread_locale != LC_GLOBAL_LOCALE)
- {
--# if __GLIBC__ >= 2 && !defined __UCLIBC__
-+# if defined(_NL_LOCALE_NAME)
-+ const char *name = nl_langinfo(_NL_LOCALE_NAME(category));
-+# if __GLIBC__ >= 2 && !defined __UCLIBC__
- /* Work around an incorrect definition of the _NL_LOCALE_NAME macro in
- glibc < 2.12.
- See <http://sourceware.org/bugzilla/show_bug.cgi?id=10968>. */
-- const char *name =
-- nl_langinfo (_NL_ITEM ((category), _NL_ITEM_INDEX (-1)));
-+ if (name[0] == '\0')
-+ name = nl_langinfo (_NL_ITEM ((category), _NL_ITEM_INDEX (-1)));
- if (name[0] == '\0')
- /* Fallback code for glibc < 2.4, which did not implement
- nl_langinfo (_NL_LOCALE_NAME (category)). */
- name = thread_locale->__names[category];
-+# endif
- return name;
- # elif defined __FreeBSD__ || (defined __APPLE__ && defined __MACH__)
- /* FreeBSD, Mac OS X */