summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-05-07 12:38:21 +0200
committerTimo Teräs <timo.teras@iki.fi>2020-10-09 16:09:19 +0300
commit718e07f78a6f5a5a1c5c1a961308bd85afb4db30 (patch)
tree52ee310d78da61233b78bd4457d2394ffcd9145b /meson.build
parentfe1de720d02ae91856ec966801f69b1f1a8e3168 (diff)
downloadapk-tools-718e07f78a6f5a5a1c5c1a961308bd85afb4db30.tar.gz
apk-tools-718e07f78a6f5a5a1c5c1a961308bd85afb4db30.tar.bz2
apk-tools-718e07f78a6f5a5a1c5c1a961308bd85afb4db30.tar.xz
apk-tools-718e07f78a6f5a5a1c5c1a961308bd85afb4db30.zip
build: build help.h with meson
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 2 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index c3fd394..d348ad5 100644
--- a/meson.build
+++ b/meson.build
@@ -13,7 +13,7 @@ apk_libdir = get_option('libdir')
zlib_dep = dependency('zlib')
openssl_dep = dependency('openssl')
lua_dep = dependency('lua' + get_option('lua_version'), required: get_option('lua'))
-scdoc = dependency('scdoc', version: '>=1.10', required: get_option('docs'))
+scdoc_dep = dependency('scdoc', version: '>=1.10', required: get_option('docs'))
add_project_arguments('-D_GNU_SOURCE', language: 'c')
@@ -23,9 +23,6 @@ if get_option('default_library') == 'static'
add_project_arguments('-DOPENSSL_NO_ENGINE', language: 'c')
endif
+subdir('doc')
subdir('libfetch')
subdir('src')
-
-if scdoc.found()
- subdir('doc')
-endif