summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-04-16 23:32:02 +0200
committerTimo Teräs <timo.teras@iki.fi>2020-10-02 12:07:05 +0300
commitdeeca54f644aba1d73b785b6eb36cd1d23e404cc (patch)
tree6ae858ddd806c94b98f197758a424038ed232117 /meson.build
parent7ccda091c2c7cf18225b861962f952dc04a5295f (diff)
downloadapk-tools-deeca54f644aba1d73b785b6eb36cd1d23e404cc.tar.gz
apk-tools-deeca54f644aba1d73b785b6eb36cd1d23e404cc.tar.bz2
apk-tools-deeca54f644aba1d73b785b6eb36cd1d23e404cc.tar.xz
apk-tools-deeca54f644aba1d73b785b6eb36cd1d23e404cc.zip
build: add support for building with meson
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build31
1 files changed, 31 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..c3fd394
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,31 @@
+project(
+ 'apk-tools',
+ ['c'],
+ default_options : ['c_std=gnu99'],
+ version: '2.10.5',
+ meson_version: '>=0.51'
+)
+pkgc = import('pkgconfig')
+
+apk_confdir = get_option('sysconfdir') / 'apk'
+apk_libdir = get_option('libdir')
+
+zlib_dep = dependency('zlib')
+openssl_dep = dependency('openssl')
+lua_dep = dependency('lua' + get_option('lua_version'), required: get_option('lua'))
+scdoc = dependency('scdoc', version: '>=1.10', required: get_option('docs'))
+
+add_project_arguments('-D_GNU_SOURCE', language: 'c')
+
+# If we're a subproject we only want the static lib and not files
+subproject = meson.is_subproject()
+if get_option('default_library') == 'static'
+ add_project_arguments('-DOPENSSL_NO_ENGINE', language: 'c')
+endif
+
+subdir('libfetch')
+subdir('src')
+
+if scdoc.found()
+ subdir('doc')
+endif