summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2021-06-09 18:21:40 +0300
committerTimo Teräs <timo.teras@iki.fi>2021-06-11 13:35:32 +0300
commit7ce4cc4b739127c0b4b36ffcabc007e5781b13c9 (patch)
tree1f751b9dc62c59a1fa1e05d34550961f39719137 /src/meson.build
parent7c9f001cda932c74164e8aaa6740dcb6d24aa62f (diff)
downloadapk-tools-7ce4cc4b739127c0b4b36ffcabc007e5781b13c9.tar.gz
apk-tools-7ce4cc4b739127c0b4b36ffcabc007e5781b13c9.tar.bz2
apk-tools-7ce4cc4b739127c0b4b36ffcabc007e5781b13c9.tar.xz
apk-tools-7ce4cc4b739127c0b4b36ffcabc007e5781b13c9.zip
add basic abstraction for cryptographic operations
- basic digesting and signing apis (subject still to fine tuning) - update digest code, and adb signing for the thin wrapping layer - old v1 package and database handling not updated - default mkpkg file hash to sha256 ref #10744
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index 4a76d4c..27dc566 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -11,6 +11,7 @@ libapk_src = [
'commit.c',
'common.c',
'context.c',
+ 'crypto_openssl.c',
'database.c',
'hash.c',
'io.c',
@@ -30,6 +31,7 @@ libapk_headers = [
'apk_atom.h',
'apk_archive.h',
'apk_blob.h',
+ 'apk_crypto.h',
'apk_database.h',
'apk_defines.h',
'apk_hash.h',