summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorAriadne Conill <ariadne@dereferenced.org>2022-03-01 09:08:19 -0600
committerTimo Teräs <timo.teras@iki.fi>2022-03-30 09:17:25 +0000
commit917698ec1d4c9a79e3580cce4cbeb56fd4fa5a96 (patch)
tree18fd0b7d0c963069dfb84607e1f8f0b1e0bc5135 /src/meson.build
parentc29638cd8143e624012041acb24fc4dc94d6121b (diff)
downloadapk-tools-917698ec1d4c9a79e3580cce4cbeb56fd4fa5a96.tar.gz
apk-tools-917698ec1d4c9a79e3580cce4cbeb56fd4fa5a96.tar.bz2
apk-tools-917698ec1d4c9a79e3580cce4cbeb56fd4fa5a96.tar.xz
apk-tools-917698ec1d4c9a79e3580cce4cbeb56fd4fa5a96.zip
use arch_prefix for this feature instead
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/meson.build b/src/meson.build
index 6ca4d68..24362d7 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -115,9 +115,9 @@ apk_cargs = [
'-D_ATFILE_SOURCE',
]
-apk_abi_tag = get_option('abi_tag')
-if apk_abi_tag != ''
- apk_cargs += ['-DAPK_ABI_TAG="@0@"'.format(apk_abi_tag)]
+apk_arch_prefix = get_option('arch_prefix')
+if apk_arch_prefix != ''
+ apk_cargs += ['-DAPK_ARCH_PREFIX="@0@"'.format(apk_arch_prefix)]
endif
libapk_shared = shared_library(