summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorAriadne Conill <ariadne@dereferenced.org>2021-12-14 13:49:15 -0600
committerTimo Teräs <timo.teras@iki.fi>2021-12-29 20:11:17 +0200
commita7a0c0a6cafd4c18d52fa436d33032170f108ec9 (patch)
treec9c1475a8dbc96f97e4dc32b48e40ece9a5923ca /src/meson.build
parent9ed4785f1ca9b6bf4c039b28511304d329bf0f9d (diff)
downloadapk-tools-a7a0c0a6cafd4c18d52fa436d33032170f108ec9.tar.gz
apk-tools-a7a0c0a6cafd4c18d52fa436d33032170f108ec9.tar.bz2
apk-tools-a7a0c0a6cafd4c18d52fa436d33032170f108ec9.tar.xz
apk-tools-a7a0c0a6cafd4c18d52fa436d33032170f108ec9.zip
portability: implement skeleton with memrchr function
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index 3cc4ce0..14a4749 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -117,6 +117,7 @@ libapk_shared = shared_library(
install: not subproject,
dependencies: [
libfetch_dep,
+ libportability_dep,
shared_deps,
],
c_args: apk_cargs,
@@ -128,6 +129,7 @@ libapk_static = static_library(
install: not subproject,
dependencies: [
libfetch_dep,
+ libportability_dep,
static_deps,
],
c_args: [apk_cargs, '-DOPENSSL_NO_ENGINE'],
@@ -158,7 +160,12 @@ if(lua_dep.found())
libluaapk = library(
'luaapk',
luaapk_src,
- dependencies: [lua_dep, libapk_dep, shared_deps],
+ dependencies: [
+ lua_dep,
+ libapk_dep,
+ shared_deps,
+ libportability_dep.partial_dependency(includes: true),
+ ],
install: true,
install_dir: lua_dep.get_pkgconfig_variable('libdir'),
c_args: apk_cargs,
@@ -173,6 +180,7 @@ apk_exe = executable(
libapk_dep,
shared_deps,
libfetch_dep.partial_dependency(includes: true),
+ libportability_dep.partial_dependency(includes: true),
],
c_args: apk_cargs,
)
@@ -185,6 +193,7 @@ if get_option('static_apk')
dependencies: [
static_deps,
libfetch_dep.partial_dependency(includes: true),
+ libportability_dep.partial_dependency(includes: true),
],
link_with: libapk_static,
c_args: [apk_cargs, '-DOPENSSL_NO_ENGINE'],