summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
new file mode 100644
index 0000000..a96a6cc
--- /dev/null
+++ b/tests/meson.build
@@ -0,0 +1,13 @@
+env = environment()
+env.set('APK', apk_exe.full_path())
+env.set('SRC', meson.current_source_dir())
+
+test_program = find_program('test-basic.sh')
+test_list = run_command(test_program, '--list').stdout().split('\n')
+
+foreach test : test_list
+ test = test.strip()
+ if test != ''
+ test(test, test_program, args: ['--test', test], env: env)
+ endif
+endforeach