summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-10-19 21:35:27 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-10-19 21:35:27 -0500
commit02a2ad393de6cbea726514226e3419db6517307c (patch)
tree000fb00ec7ec9a4a963a21ae3e2a770a5de8179f /CMakeLists.txt
parentf1ef45bd84b57b40b701e094a9b49daac3761f9f (diff)
downloadhorizon-02a2ad393de6cbea726514226e3419db6517307c.tar.gz
horizon-02a2ad393de6cbea726514226e3419db6517307c.tar.bz2
horizon-02a2ad393de6cbea726514226e3419db6517307c.tar.xz
horizon-02a2ad393de6cbea726514226e3419db6517307c.zip
hscript: Implement Firmware, and add tests
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 16f9f58..faf04d2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,13 @@ option(BUILD_TOOLS "Enable building of tools (Validator, Simulator, etc)" ON)
option(COVERAGE "Build for code coverage tests (slow)" OFF)
option(VALGRIND "Run Valgrind during test phase" OFF)
+option(FIRMWARE "Support loading and installation of non-libre firmware (DANGEROUS)" OFF)
+mark_as_advanced(FORCE FIRMWARE)
+
+IF(FIRMWARE)
+ add_definitions(-DNON_LIBRE_FIRMWARE)
+ENDIF(FIRMWARE)
+
IF(COVERAGE)
SET(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} --coverage")
SET(CMAKE_EXE_LINKER_FLAGS_DEBUG "${CMAKE_EXE_LINKER_FLAGS_DEBUG} --coverage")