summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-11-07 22:44:57 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-11-07 22:44:57 -0600
commit3ab436a3d897b7fc76ed9e1718198bc6f012e286 (patch)
treec92f5918729758ec15edcf73ac3da2d28e28aa5f /CMakeLists.txt
parent269974f16e187d3001a5ee01f7bc20944deb3085 (diff)
downloadhorizon-3ab436a3d897b7fc76ed9e1718198bc6f012e286.tar.gz
horizon-3ab436a3d897b7fc76ed9e1718198bc6f012e286.tar.bz2
horizon-3ab436a3d897b7fc76ed9e1718198bc6f012e286.tar.xz
horizon-3ab436a3d897b7fc76ed9e1718198bc6f012e286.zip
Build: Might as well coverage C as well
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4396927..7ec75ca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,6 +24,7 @@ option(BUILD_TOOLS "Enable building of tools (Validator, Simulator, etc)" ON)
## Code Coverage stuff ##
option(COVERAGE "Build for code coverage tests (slow)" OFF)
IF(COVERAGE)
+ SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} --coverage")
SET(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} --coverage")
SET(CMAKE_EXE_LINKER_FLAGS_DEBUG "${CMAKE_EXE_LINKER_FLAGS_DEBUG} --coverage")
ENDIF(COVERAGE)