summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-06-22 21:50:30 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-06-22 21:50:30 -0500
commitc7a38e3e9ab868526b2953d3094c4be8da5ed97c (patch)
tree60354674d146172fc08fe5616a36ecfb137afe34 /CMakeLists.txt
parent251ea4440f39b078796fb0bb8249f295a23054af (diff)
downloadhorizon-c7a38e3e9ab868526b2953d3094c4be8da5ed97c.tar.gz
horizon-c7a38e3e9ab868526b2953d3094c4be8da5ed97c.tar.bz2
horizon-c7a38e3e9ab868526b2953d3094c4be8da5ed97c.tar.xz
horizon-c7a38e3e9ab868526b2953d3094c4be8da5ed97c.zip
CMake: Ensure BCNM is only searched for in UI mode
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7d935ac..9e0e8c8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -74,11 +74,6 @@ IF(INSTALL)
pkg_check_modules(BLKID REQUIRED blkid)
pkg_check_modules(LIBUDEV REQUIRED libudev)
pkg_check_modules(PARTED REQUIRED libparted)
- find_library(SKARNET NAMES skarnet)
- find_library(BCNM NAMES wpactrl PATH_SUFFIXES bcnm)
- if(BCNM STREQUAL "BCNM-NOTFOUND")
- message(FATAL_ERROR "BCNM is required for the Installation Environment.")
- endif()
set(BUILD_SHARED_LIBS ON)
option(BUILD_IMAGE "Enable building the image creation tools" ON)