summaryrefslogtreecommitdiff
path: root/hscript/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-05-07 21:58:23 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-05-07 21:58:23 -0500
commit78e398856a9a8bb929a596aa5b2fa148403d56e4 (patch)
tree9b29a1162d46c6c921e46262cbe7672335cde1de /hscript/CMakeLists.txt
parentcd52d492ec08810fa0ba2425d5e01618a2e8741a (diff)
downloadhorizon-78e398856a9a8bb929a596aa5b2fa148403d56e4.tar.gz
horizon-78e398856a9a8bb929a596aa5b2fa148403d56e4.tar.bz2
horizon-78e398856a9a8bb929a596aa5b2fa148403d56e4.tar.xz
horizon-78e398856a9a8bb929a596aa5b2fa148403d56e4.zip
image: Add functional TAR backend
Diffstat (limited to 'hscript/CMakeLists.txt')
-rw-r--r--hscript/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/hscript/CMakeLists.txt b/hscript/CMakeLists.txt
index 1f8c358..ff35372 100644
--- a/hscript/CMakeLists.txt
+++ b/hscript/CMakeLists.txt
@@ -23,13 +23,7 @@ target_compile_features(hscript PUBLIC cxx_unicode_literals)
if("cxx_std_17" IN_LIST CMAKE_CXX_COMPILE_FEATURES)
set_property(TARGET hscript PROPERTY CXX_STANDARD 17)
- SET(FS_LIBRARY stdc++fs)
- add_definitions(-DFS_IS_STDCXX)
-ELSE()
- find_package(Boost REQUIRED COMPONENTS filesystem)
- SET(FS_LIBRARY ${Boost_FILESYSTEM_LIBRARY})
- add_definitions(-DFS_IS_BOOST)
-ENDIF()
+endif()
target_link_libraries(hscript ${BLKID_LIBRARIES} ${FS_LIBRARY} ${LIBUDEV_LIBRARIES} ${PARTED_LIBRARIES})