summaryrefslogtreecommitdiff
path: root/image/backends/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-05-07 21:58:23 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-05-07 21:58:23 -0500
commit78e398856a9a8bb929a596aa5b2fa148403d56e4 (patch)
tree9b29a1162d46c6c921e46262cbe7672335cde1de /image/backends/CMakeLists.txt
parentcd52d492ec08810fa0ba2425d5e01618a2e8741a (diff)
downloadhorizon-78e398856a9a8bb929a596aa5b2fa148403d56e4.tar.gz
horizon-78e398856a9a8bb929a596aa5b2fa148403d56e4.tar.bz2
horizon-78e398856a9a8bb929a596aa5b2fa148403d56e4.tar.xz
horizon-78e398856a9a8bb929a596aa5b2fa148403d56e4.zip
image: Add functional TAR backend
Diffstat (limited to 'image/backends/CMakeLists.txt')
-rw-r--r--image/backends/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/image/backends/CMakeLists.txt b/image/backends/CMakeLists.txt
index 726d4eb..2c79c8e 100644
--- a/image/backends/CMakeLists.txt
+++ b/image/backends/CMakeLists.txt
@@ -14,3 +14,7 @@ endif()
add_library(hi-backends ${BACKEND_SRCS})
target_link_libraries(hi-backends ${BACKEND_LIBS})
install(TARGETS hi-backends DESTINATION lib)
+
+if("cxx_std_17" IN_LIST CMAKE_CXX_COMPILE_FEATURES)
+ set_property(TARGET hi-backends PROPERTY CXX_STANDARD 17)
+endif()