summaryrefslogtreecommitdiff
path: root/ui/qt5/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-11-08 22:50:40 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-11-09 02:02:13 -0600
commit01e92019e6616d46a85beb5db6ddb84f58e253b6 (patch)
treee3bd5af3fdd8c610a2b823e6ec64a5454e36bf80 /ui/qt5/CMakeLists.txt
parent61b3bc944db6787711eb7a3f572ac4a306deca8b (diff)
downloadhorizon-01e92019e6616d46a85beb5db6ddb84f58e253b6.tar.gz
horizon-01e92019e6616d46a85beb5db6ddb84f58e253b6.tar.bz2
horizon-01e92019e6616d46a85beb5db6ddb84f58e253b6.tar.xz
horizon-01e92019e6616d46a85beb5db6ddb84f58e253b6.zip
Qt UI: Implement UI.Input page
Diffstat (limited to 'ui/qt5/CMakeLists.txt')
-rw-r--r--ui/qt5/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/ui/qt5/CMakeLists.txt b/ui/qt5/CMakeLists.txt
index 38ede75..0dd441b 100644
--- a/ui/qt5/CMakeLists.txt
+++ b/ui/qt5/CMakeLists.txt
@@ -8,6 +8,7 @@ set(UI_SOURCES
main.cc
intropage.cc
+ inputpage.cc
networkingpage.cc
horizon.qrc)
@@ -17,5 +18,8 @@ target_link_libraries(horizon-qt5 Qt5::Widgets)
install(TARGETS horizon-qt5 DESTINATION bin)
IF(INSTALL)
+ pkg_check_modules(XKBFile REQUIRED xkbfile)
+ pkg_check_modules(LIBX11 REQUIRED x11)
+ target_link_libraries(horizon-qt5 ${LIBX11_LIBRARIES} ${XKBFile_LIBRARIES})
# add_executable(horizon-run-qt5 ${RUN_QT_SOURCES})
ENDIF(INSTALL)