summaryrefslogtreecommitdiff
path: root/ui/qt5/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-05 03:36:39 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-05 03:36:39 -0600
commit04a397afdeddf08173313be429648f6f3492045d (patch)
treea69111941e0e13aa335a2dad4439dcd6e4aef46b /ui/qt5/CMakeLists.txt
parentf4801b8134c88718f49292470fddf01cd630a57f (diff)
downloadhorizon-04a397afdeddf08173313be429648f6f3492045d.tar.gz
horizon-04a397afdeddf08173313be429648f6f3492045d.tar.bz2
horizon-04a397afdeddf08173313be429648f6f3492045d.tar.xz
horizon-04a397afdeddf08173313be429648f6f3492045d.zip
Qt UI: Initial draft of outputting a HorizonScript file from the UI
Diffstat (limited to 'ui/qt5/CMakeLists.txt')
-rw-r--r--ui/qt5/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/ui/qt5/CMakeLists.txt b/ui/qt5/CMakeLists.txt
index 9ac6372..7fd1ebf 100644
--- a/ui/qt5/CMakeLists.txt
+++ b/ui/qt5/CMakeLists.txt
@@ -31,7 +31,11 @@ ENDIF(UNSUPPORTED_NONFREE_FIRMWARE)
include_directories(${CMAKE_SOURCE_DIR}/3rdparty)
add_executable(horizon-qt5 ${UI_SOURCES})
-target_link_libraries(horizon-qt5 Qt5::Network Qt5::Widgets)
+target_link_libraries(horizon-qt5 Qt5::Network Qt5::Widgets crypto)
+
+IF("cxx_std_17" IN_LIST CMAKE_CXX_COMPILE_FEATURES)
+ set_property(TARGET horizon-qt5 PROPERTY CXX_STANDARD 17)
+ENDIF()
install(TARGETS horizon-qt5 DESTINATION bin)