summaryrefslogtreecommitdiff
path: root/ui/qt5/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-02-10 10:55:42 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-02-10 10:55:42 -0600
commit04f0270f9a5f28ec1d2fa029d7ee78c8d0e5f9b2 (patch)
tree47995177c2f1d798e4911a36704a535286b10d1e /ui/qt5/CMakeLists.txt
parentf994d06fa1e60d7759bb6363573185757d8435d1 (diff)
downloadhorizon-04f0270f9a5f28ec1d2fa029d7ee78c8d0e5f9b2.tar.gz
horizon-04f0270f9a5f28ec1d2fa029d7ee78c8d0e5f9b2.tar.bz2
horizon-04f0270f9a5f28ec1d2fa029d7ee78c8d0e5f9b2.tar.xz
horizon-04f0270f9a5f28ec1d2fa029d7ee78c8d0e5f9b2.zip
Qt UI: Improvements to the Runner's Error Page
Diffstat (limited to 'ui/qt5/CMakeLists.txt')
-rw-r--r--ui/qt5/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/ui/qt5/CMakeLists.txt b/ui/qt5/CMakeLists.txt
index cc56ed4..a8779fd 100644
--- a/ui/qt5/CMakeLists.txt
+++ b/ui/qt5/CMakeLists.txt
@@ -72,4 +72,7 @@ IF(INSTALL)
add_executable(horizon-run-qt5 ${RUN_QT_SOURCES})
target_link_libraries(horizon-run-qt5 Qt5::Widgets)
target_compile_definitions(horizon-run-qt5 PRIVATE IN_RUNNER)
+ IF("cxx_std_17" IN_LIST CMAKE_CXX_COMPILE_FEATURES)
+ set_property(TARGET horizon-run-qt5 PROPERTY CXX_STANDARD 17)
+ ENDIF()
ENDIF(INSTALL)