summaryrefslogtreecommitdiff
path: root/ui/qt5/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-11-08 02:38:58 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-11-08 02:38:58 -0600
commit386ff62ca3aba790f9831ee7c194d24f6fb781fe (patch)
tree9bb4233e965f3fe71224fd0a5983c1e631787ae4 /ui/qt5/CMakeLists.txt
parent561db34595bd4181fde3781d3a00bab9a6d1403f (diff)
downloadhorizon-386ff62ca3aba790f9831ee7c194d24f6fb781fe.tar.gz
horizon-386ff62ca3aba790f9831ee7c194d24f6fb781fe.tar.bz2
horizon-386ff62ca3aba790f9831ee7c194d24f6fb781fe.tar.xz
horizon-386ff62ca3aba790f9831ee7c194d24f6fb781fe.zip
UI: Import some of the 2016 prototype - welcome to Qt UI development
Diffstat (limited to 'ui/qt5/CMakeLists.txt')
-rw-r--r--ui/qt5/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/ui/qt5/CMakeLists.txt b/ui/qt5/CMakeLists.txt
new file mode 100644
index 0000000..5620cf7
--- /dev/null
+++ b/ui/qt5/CMakeLists.txt
@@ -0,0 +1,19 @@
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+
+set(UI_SOURCES
+ horizonwizard.cc
+ horizonwizardpage.cc
+ horizonhelpwindow.cc
+ main.cc
+
+ intropage.cc
+ networkingpage.cc
+
+ horizon.qrc)
+add_executable(horizon-qt5 ${UI_SOURCES})
+target_link_libraries(horizon-qt5 Qt5::Widgets)
+
+IF(INSTALL)
+ # add_executable(horizon-run-qt5 ${RUN_QT_SOURCES})
+ENDIF(INSTALL)