summaryrefslogtreecommitdiff
path: root/ui/qt5/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-07 05:05:30 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-07 05:05:30 -0600
commit5287ea303f22f937df8f4b61b67f7bc163138b99 (patch)
tree10c3bd8b010501d25079df4538821dd31aed7230 /ui/qt5/CMakeLists.txt
parent8c48b20bb7433c69228447bce4e5744bf658dc3d (diff)
downloadhorizon-5287ea303f22f937df8f4b61b67f7bc163138b99.tar.gz
horizon-5287ea303f22f937df8f4b61b67f7bc163138b99.tar.bz2
horizon-5287ea303f22f937df8f4b61b67f7bc163138b99.tar.xz
horizon-5287ea303f22f937df8f4b61b67f7bc163138b99.zip
Qt UI: Add executor/runner
Diffstat (limited to 'ui/qt5/CMakeLists.txt')
-rw-r--r--ui/qt5/CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/ui/qt5/CMakeLists.txt b/ui/qt5/CMakeLists.txt
index e752749..930a84a 100644
--- a/ui/qt5/CMakeLists.txt
+++ b/ui/qt5/CMakeLists.txt
@@ -26,6 +26,15 @@ set(UI_SOURCES
horizon.qrc)
+set(RUN_QT_SOURCES
+ horizonwizardpage.cc
+ runner/main.cc
+ runner/executorwizard.cc
+ runner/executepage.cc
+ runner/finishedpage.cc
+
+ horizon.qrc)
+
IF(INSTALL)
LIST(APPEND UI_SOURCES commitpage.cc)
ELSE(INSTALL)
@@ -51,5 +60,7 @@ IF(INSTALL)
pkg_check_modules(LIBX11 REQUIRED x11)
pkg_check_modules(LibCap REQUIRED libcap)
target_link_libraries(horizon-qt5 ${BCNM} ${SKARNET} ${LIBUDEV_LIBRARIES} ${LibCap_LIBRARIES} ${LIBX11_LIBRARIES} ${XKBFile_LIBRARIES})
- # add_executable(horizon-run-qt5 ${RUN_QT_SOURCES})
+ add_executable(horizon-run-qt5 ${RUN_QT_SOURCES})
+ target_link_libraries(horizon-run-qt5 Qt5::Widgets)
+ target_compile_definitions(horizon-run-qt5 PRIVATE IN_RUNNER)
ENDIF(INSTALL)