summaryrefslogtreecommitdiff
path: root/ui/qt5/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-11-15 14:36:03 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-11-15 14:36:03 -0600
commit5967de4afb4e00f136baab49cacd11b7f9b725bb (patch)
tree96b2c89aae3bded09c230b1a8d39973d746d6c71 /ui/qt5/CMakeLists.txt
parent77a4ad101732fa77ff7253bc6bda06c180a9fe2a (diff)
downloadhorizon-5967de4afb4e00f136baab49cacd11b7f9b725bb.tar.gz
horizon-5967de4afb4e00f136baab49cacd11b7f9b725bb.tar.bz2
horizon-5967de4afb4e00f136baab49cacd11b7f9b725bb.tar.xz
horizon-5967de4afb4e00f136baab49cacd11b7f9b725bb.zip
Qt UI: Add UI.Network.Automatic page and logic
Diffstat (limited to 'ui/qt5/CMakeLists.txt')
-rw-r--r--ui/qt5/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/ui/qt5/CMakeLists.txt b/ui/qt5/CMakeLists.txt
index af7fd82..a5c88ab 100644
--- a/ui/qt5/CMakeLists.txt
+++ b/ui/qt5/CMakeLists.txt
@@ -12,12 +12,13 @@ set(UI_SOURCES
networkingpage.cc
networkifacepage.cc
netsimplewifipage.cc
+ netdhcppage.cc
datetimepage.cc
hostnamepage.cc
horizon.qrc)
add_executable(horizon-qt5 ${UI_SOURCES})
-target_link_libraries(horizon-qt5 Qt5::Widgets)
+target_link_libraries(horizon-qt5 Qt5::Network Qt5::Widgets)
install(TARGETS horizon-qt5 DESTINATION bin)