summaryrefslogtreecommitdiff
path: root/ui/qt5/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-11-19 23:01:41 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-11-19 23:01:41 -0600
commit5a2edfafa2465ee615eece5655601be96d7c0cde (patch)
tree98800c6efeb798664307aae7d3fc730bfe411f22 /ui/qt5/CMakeLists.txt
parentaf7111f3750eec9b90b6025297c522b97952cd38 (diff)
downloadhorizon-5a2edfafa2465ee615eece5655601be96d7c0cde.tar.gz
horizon-5a2edfafa2465ee615eece5655601be96d7c0cde.tar.bz2
horizon-5a2edfafa2465ee615eece5655601be96d7c0cde.tar.xz
horizon-5a2edfafa2465ee615eece5655601be96d7c0cde.zip
Qt UI: Add UI.Boot page
Diffstat (limited to 'ui/qt5/CMakeLists.txt')
-rw-r--r--ui/qt5/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/ui/qt5/CMakeLists.txt b/ui/qt5/CMakeLists.txt
index 72500ba..7b955b7 100644
--- a/ui/qt5/CMakeLists.txt
+++ b/ui/qt5/CMakeLists.txt
@@ -6,6 +6,7 @@ set(UI_SOURCES
horizonwizardpage.cc
horizonhelpwindow.cc
main.cc
+ ${CMAKE_SOURCE_DIR}/3rdparty/Section.cpp
intropage.cc
inputpage.cc
@@ -16,6 +17,7 @@ set(UI_SOURCES
datetimepage.cc
hostnamepage.cc
pkgsimple.cc
+ bootpage.cc
horizon.qrc)
@@ -23,6 +25,7 @@ IF(UNSUPPORTED_NONFREE_FIRMWARE)
LIST(APPEND UI_SOURCES firmwarepage.cc)
ENDIF(UNSUPPORTED_NONFREE_FIRMWARE)
+include_directories(${CMAKE_SOURCE_DIR}/3rdparty)
add_executable(horizon-qt5 ${UI_SOURCES})
target_link_libraries(horizon-qt5 Qt5::Network Qt5::Widgets)