summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bc07267..0600bbf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,7 +69,10 @@ IF(INSTALL)
pkg_check_modules(BLKID REQUIRED blkid)
pkg_check_modules(LIBUDEV REQUIRED libudev)
pkg_check_modules(PARTED REQUIRED libparted)
- find_library(BCNM_LIBRARY REQUIRED wpactrl PATH_SUFFIXES bcnm)
+ find_library(BCNM NAMES wpactrl PATH_SUFFIXES bcnm)
+ if(BCNM STREQUAL "BCNM-NOTFOUND")
+ message(FATAL_ERROR "BCNM is required for the Installation Environment.")
+ endif()
set(BUILD_SHARED_LIBS ON)
add_subdirectory(executor)